1

Prior to Sonoma, when using TextEdit (virtually always editing rich text docs), I could select any text and add/remove a style to whatever styles were present in the text. For example, if I had a sentence: This is an example of bold, and I wanted to use italics for the whole sentence, I simply selected the whole sentence and clicked the I button. Simple, and common to most editors.

In Sonoma, however, if I select the wole sentence, the menu options become gray/disabled. I am forced to first select the non-bold part, italicize it, then select the bold part, and italicize that. Since I edit docs extensively, this requires a LOT of extra time.

I've searched haven't found anyone else mentioning this change, so I'm wondering if it is specific to my machine? Or some setting I'm missing? Thanks in advance for any suggestions.

2
  • Works for me as far as I can tell, but it would depend if the particular typeface has an italic style - what fonts are you using?
    – red_menace
    Jan 14 at 1:20
  • I'm using Helvetica. If I bold or italicize a word in a sentence, then select the whole sentence, the menu is disabled. If I underline a word then select the whole sentence, the menu stays enabled. so the issue seems to target certain styles. I tried Arial with the same results. Selecting a sentence with mixed styles (some combination of regular, bold, and/or italics) disables the styles parts of the menu.
    – iMobyl
    Jan 14 at 16:38

1 Answer 1

0

I have reproduced the same behaviour on macOS 14.2.1, TextEdit 1.19 (404), it seems to be a bug.

Steps to reproduce

  1. If the format is not already in rich text, from the menu:

    Format -> Make Rich Text

  2. Type "abc def ghi"

  3. Set "def" in bold

  4. Select all the text

Observed behavior

The buttons "B" and "I" are greyed out.

Desired behavior

The buttons "B" and "I" should not be greyed out. Clicking on them should have the same behavior as hitting Cmd ⌘ B and Cmd ⌘ I , i.e. applying the style on all selected text.

enter image description here

Workaround

There is a simple workaround. When the menu options are disabled, you can simply use the shortcuts Cmd ⌘ B and Cmd ⌘ I . They work as intended.

Reproduced on:

  • macOS 14.2.1, TextEdit 1.19 (404)
  • macOS 14.3, TextEdit 1.19 (404)
  • macOS 14.3.1, TextEdit 1.19 (404)
  • macOS 14.4, TextEdit 1.19 (404)
  • macOS 14.4.1, TextEdit 1.19 (404)
2
  • You should send your reportage to Apple Product Feedback.
    – IconDaemon
    Jan 14 at 3:35
  • 1
    Thank you, Ortomala, for verifying, and the suggested work-around which works for me as well. I have reported the issue to Apple Product Feedback (to the MacOs category as they don't have a category specific to TextEdit) as suggested by IconDaemon.
    – iMobyl
    Jan 14 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .