0

I broke my laptop some how (I think from overheating). I dual-boot linux on a Macbook that has got a T2 chip. I can't boot up MacOS, but for some reason linux does. I've got a couple of files in my MacOS that I really need.

My first thought was to try and mount the apfs partition in linux to get the files. None of the online tools for this worked except for linux-apfs-rw which was only able to mount most of the root directory but not the home directory.

I've heard T2 chips security prevents you from reading the contents of the apfs but not sure if that's true.

Would anyone know of a way to extract the files or mount the full apfs partition?

If I need to provide more information please ask!

3
  • If it still boots Linux, it can't be (fully) broken. What happens if you try to boot into macOS? I know that this is not what you are asking, but getting macOS to work again may be easier than accessing an encrypted disk.
    – nohillside
    Commented Jan 12 at 15:00
  • That's a valid point. When I boot up MacOS it just crashes. I don't know why, or how. I've tried booting it into safe and recovery mode and that just crashes as well. Maybe when I get the files I'll need to factory reset it. Commented Jan 13 at 1:05
  • @sherbitfish I have the same issue, what did you do?
    – Peril
    Commented Mar 25 at 6:57

0

You must log in to answer this question.

Browse other questions tagged .