0

Connect to the host using SSH at the specified IP address @Visual Studio Code.

Issue: There is a recurring problem where, after approximately 30-40 minutes, the system automatically logs out from the specified IP address, prompting the user to re-enter the password. Is there a solution available to disable this automatic logout feature for SSH connections to ? Alternatively, is there a setting to adjust the auto-logout timer?

PS: I am currently using Version 1.85.1 (Universal) on my Mac.

4
  • On what kind of system does VSCode run, into which system to you log in via SSH? If you log in via Terminal.app (instead of via VSCode), does the auto-logout happen as well? Does it happen only with this one specific remote system, or with all SSH logins?
    – nohillside
    Commented Jan 9 at 13:10
  • I am logging using visual studio {Connect to Host option}
    – subbu
    Commented Jan 10 at 10:51
  • Can you please start Terminal.app, log in from there (ssh user@host) and wait an hour to see if you get logged out as well? This will tell us whether it is a VSCode issue or something with either ssh or the remote host.
    – nohillside
    Commented Jan 10 at 10:57
  • It is VSCode issue only.
    – subbu
    Commented Jan 11 at 6:26

0

You must log in to answer this question.

Browse other questions tagged .