0

So a bit of background: I originally had a couple partitions on my macOS hard drive that I recently removed. I've done this before so pretty simple. I then try to run diskutil apfs resizeContainer disk0s2 0 and although it is successful, the actual APFS volume doesn't claim the new space.

Results from diskutil list:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         1.0 TB     disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1.0 TB     disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD - Data     784.2 GB   disk1s1
   2:                APFS Volume Preboot                 3.7 GB     disk1s2
   3:                APFS Volume Recovery                1.2 GB     disk1s3
   4:                APFS Volume VM                      24.6 KB    disk1s4
   5:                APFS Volume Macintosh HD            9.8 GB     disk1s5
   6:              APFS Snapshot com.apple.os.update-... 9.8 GB     disk1s5s1

I have found similar questions asked listed below. None of their solutions have worked for me thus far. Also, I am trying to avoid doing a fresh install of macOS.

3
  • I don't see the problem. The disk0 size = disk0s2 size = disk1 size = 1.0 TB. Commented Jan 5 at 20:54
  • @DavidAnderson You know what, I just was rereading the problem and realized I fixed it lol. I will remove question. I ended up using the limits command to reduce the size and then resize to 1 TB.
    – Harrison G
    Commented Jan 5 at 20:59
  • That is one way to fix the problem. Commented Jan 5 at 20:59

0

You must log in to answer this question.

Browse other questions tagged .