0

I've been having an issue for a while now in that I have not been getting e-mail notifications on my iPhone [and my Apple Watch by extension] - this includes both the Outlook and Gmail apps, and I do not use the native Mail app.

Device: iPhone 11
iOs Version: 17.2.1

Outlook App Version: 4.2347.1
Gmail App Version: 6.0.231127.1784698
  • Have restarted phone many times (once every few days)
  • All notification settings for both apps are turned on and Banner Style is set to Persistent
  • Have tried enabling Background App Refresh on both apps
  • Gmail notifications set to "Primary [inbox] only"
  • Outlook notifications set to "Focused and Other Inboxes"
    • nothing was selected when I originally checked this
    • sounds are enabled for sending and receiving
  • Outlook Calendar (same app) notifications push through correctly
  • When I try the Test Push Notifications option in Outlook's Help & Feedback - Troubleshooting section, I get the following error message:

Notification Test Failed

There was an error receiving the push notification for your account [email protected]. Please contact support if the issue persists.

  • This is occurring for three separate e-mail addresses, one in Outlook and two in Gmail
  • The main Notifications DISPLAY AS Setting is set to Stack
  • Happens on both WIFI and Cellular
  • Have not had any issues with any other apps sending notifications

I've tried toggling all sorts of other stuff on and off and I haven't been able to see any difference. I really would rather not reset my phone so I wanted to reach out and see if any of you can think of anything else to try - I have not found anything online that is helpful nor do I know a better place to ask.

4
  • 1
    It belongs in Ask Different.
    – John
    Jan 4 at 19:29
  • Thanks guys, I had no idea at a glance that Ask Different was the Apple section.
    – mael'
    Jan 4 at 20:58
  • 1
    Tear down and rebuild the Gmail and Outlook account settings and see if that helps.
    – IconDaemon
    Jan 5 at 2:47
  • @IconDaemon for some reason deleting the apps and reinstalling them a second time fixed it - though the second time it did make me update my CC info in Wallet, so it could be related; the settings even looked different upon reinstalling Outlook (Focused Inbox and such). I don't know why it didn't work the first time or why it hit both apps at the same time, but if you write up and post the answer I will certainly give it to you.
    – mael'
    Jan 5 at 13:38

1 Answer 1

1

There are two possible solutions which sound drastic, but really aren't.

  1. Tear down (delete) your account settings for each affected app, then recreate them with known working credentials. If this doesn't work, then:
  2. Delete the affected app(s) from the device. You are given the option of deleting the data used by the app, which may contain configuration information. If you keep the data, and the problem continues, delete the app again, and wipe out the data. Download the app(s) and set up your accounts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .