2

I today performed a factory reset on my Early 2009 iMac by going into the recovery mode, erasing the disk (as per this video). I then quit the disk utility application and proceeded for a fresh install of OSX. When I tried doing so, the prompt asked for my apple id and password, which I did not want to give (since I was planning to give away this mac). Thus after referring to this link, I restarted the mac without doing a fresh install and tried to load the most recent compatible OS by pressing the Shift-Option-Command-R key combination.

The Mac did not boot up after restart and has been stuck on a blank white screen. I have tried holding the power button for 10 seconds and restarting, booting in safe mode, booting on verbose mode, holding the CMD+Shift+P+R combination but the mac still does not boot and is stuck on the blank white screen.

Thus, how can I get the mac to boot up?

1
  • 4
    I'm afraid you were using instructions not applicable to such an old Mac. Internet recovery is not available on an '09, it started to appear in '10/11 models. You need to make a USB boot stick - see apple.stackexchange.com/questions/309399/…
    – Tetsujin
    Commented Dec 31, 2023 at 18:51

1 Answer 1

1

You will need to bring a working OS to your Mac or bring it to another computer to wipe. There's likely not enough OS left internally and it won't boot from Internet Recovery.

Here's a very excellent write up of the preparation process for next time (once you've gotten it booted again or perform some of the steps from another computer like removing Activation Lock)

2
  • Thanks for replying, I made a bootable usb of el capitan as per this answer: apple.stackexchange.com/a/388508/451757. But on inserting the usb and holding down the option key while starting the machine. The mac still has a white screen. Any fixes for this?
    – Shaurya
    Commented Dec 31, 2023 at 20:27
  • If you reset NVRAM one time - what shows on the screen when you hold option and start it up? @Shaurya (if it’s always white, you have a coincidental hardware failure unrelated to the OS things you’ve done.)
    – bmike
    Commented Dec 31, 2023 at 21:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .