0

My friend and I use our MacBooks from a local coffee shop sitting at the same table. My Wifi connection is much worse than hers is. Using option + click on the 🛜 menu, which reveals network information, I see that we are on different channels:

  • 108 (5 GHz 80 MHz) works fine for my friend
  • 11 (2.4 GHz 20 MHz) is slow for me

I would like to reconnect on chanel 108, to match her configuration. Hopefully this will improve my connection.

Things I've tried

Per Apple's support forums, I tried this command:

sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport --channel=108

This command has no immediate effect. Repeating the command with the -c flag, which shows the channel number, indicates that it stays at 11. However, if I repeat the command with the -z flag, which disconnects the connection, the channel does become 108, but only briefly. When I reconnect to the WiFi, it reverts to channel 11.

When I scan all networks with the -s flag, I see two items listed with the same SSID, one at channel 11 and one at 108. So, the channel I want is "right there" and my laptop just isn't using it.

Someone else on Stack Exchange asked a similar question years ago, and was told that the channel simply cannot be changed except at the WAP. Naturally in a coffee shop I don't have access to the WAP. As my friend is able to use the other channel it seems to me it's a matter of configuration in our laptops. How can I change the channel?

I am on a MacBook Pro running Sonoma 14.2.1

4
  • Throughput is not a metric that will be applied by the software to choose a band/channel. Signal strength (RSSI) may be. Where I am at the moment, my MBP sees the same network (same AP for both, one room away) at -42 on channel 1 (2.4 ghz) and -52 on channel 36 (5 ghz) and is currently connected to the AP on channel 36. So the channel with lower signal strength was chosen. Jan 28 at 22:01
  • Right, as you found a lot of people seem to misunderstand what the --channel flag does. You'll want to use something like github.com/braineo/airport-bssid to connect to a specific BSSID instead (internally it uses CoreWLAN). I believe you may also need to disable roaming (gist.github.com/donalod/3e0885dcc5c786b8538e) (com.apple.airport.opproam)
    – 1110101001
    Apr 10 at 3:57
  • (well actually the roaming mode prefs seem to no longer work after Yosemite. Pity)
    – 1110101001
    Apr 10 at 4:00
  • (also linking apple.stackexchange.com/questions/131852/…)
    – 1110101001
    Apr 10 at 4:01

1 Answer 1

0

There must be some conflict

  • the 2.4 G does not have channel 108

  • the 5G has it

. Start by removing that SSID

Goto System preferences > Network > Advanced

Select the SSID in question and click on the (-) sign, click OK, and click Apply to complete the process of removing it

Now start over fresh selecting the correct SSID

You are the guest (user) and can not choose the channel, only the router owner can do that

1
  • 1
    Both 2.4 and 5 ghz can certainly host the same SSID. Jan 28 at 21:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .