0

I used my external disk on my Sierra device. When I was done, I disconnected it from the Eject feature and set it aside. A few weeks later I installed it on my Ventura. It can see my external disk but cannot connect to it. I repaired the disk but it shows that the EFI partition is damaged. How can I access my data?

EDIT: I tried mounting it. Failed. I've been trying through the terminal, but I haven't gotten any results.

[I tried to solve this problem by contacting WD support department, but instead of helping, they wanted to replace the disk.]

Disk Utility

EFI

3
  • Does it still work on the "High Sierra" Mac? That would tell you if the problem is with the drive or the "Ventura" Mac. Commented Dec 10, 2023 at 14:37
  • Thank you, Steve for replay. No. I see it in the Disk Utility software in Sierra, but I cannot access my files. Everything is as it seems in Ventura. Commented Dec 11, 2023 at 10:52
  • Well, if it is fine on Mac "A" and not fine on Mac "B" then the problem is likely with Mac "B". In rare occasions I have seen peripherals, cables and whatnot work on one computer just fine and not on another. There is a slim chance that the issue is with the cable, the case that the drive is in or the drive itself. I would be tempted to replace it. Computers are complex beasts and sometimes an error not noticed by one computer fails completely on another. If the replacement drive still exhibits the same symptoms, then you need to look at Mac "B" as the problem and not the drive. Commented Dec 11, 2023 at 23:52

0

You must log in to answer this question.

Browse other questions tagged .