0

First, I have Time Machine enabled and my aim is to make rclone cloud backups of a snapshot of all locally backed up files, excluding system files. It is mainly non-system volumes and $HOME. I am able to mount non-bootable snapshots from the command line. So far, haven't been able to mount bootable ones. This is on macOS 14.1.2. Apple Silicon, but that likely doesn't matter.

I start with this to make a snapshot:

$ tmutil snapshot

and the response is:

NOTE: local snapshots are considered purgeable and may be removed at any time by deleted(8).
Created local snapshot with date: 2023-12-06-202527

Then, I find the snapshots just made:

$ diskutil apfs listSnapshots /Volumes/me |grep Name: |tail -1
    Name:        com.apple.TimeMachine.2023-12-06-202527.local
$

I can mount this:

mount_apfs -o ro -s com.apple.TimeMachine.2023-12-06-202527.local /Volumes/me ~/tmp/snapshot

All fine. However, when I try to do this for the / snapshot I get a snapshot name of com.apple.os.update-E071D10CC651CAA7FA82B6ABD01FB1E761A267F6EA0104F2743F887F5B4BCC8C and

$ sudo mount_apfs -o ro -s com.apple.os.update-E071D10CC651CAA7FA82B6ABD01FB1E761A267F6EA0104F2743F887F5B4BCC8C / ~/tmp/snapshot
mount_apfs: volume could not be mounted: Resource busy
$ 

I can use the GUI for diskutil and mount the same / snapshot and I get an interesting warning:

enter image description here

This is why I tried sudo for the mount_apfs command above for the failing case. I tried it without and it does the same thing. I also tried varying the mount location from ~/tmp/snapshot to /tmp/snapshot, etc. Nothing worked.

2
  • Just in case you're not aware, since macOS Catalina, system files are stored on a seperate volume of the disk. This went a step further in macOS Big Sur with the introduction of Signed System Volumes (SSV). Read up about SSV, because making changes to the System Volume requires jumping through multiple hoops to disable the authenticated root, mounting the system volume, making the changes and then creating a snapshot and blessing the changes. Be careful, because if you haven't done the correct steps, macOS won't be able to boot up.
    – AVelj
    Commented Dec 7, 2023 at 23:39
  • It's the non-system files I'm interested in. Really just /Users/$USER. I can mount the snapshot using the GUI and use rclone on it fine. This entire thing is just about doing it automatically via the command line.
    – e40
    Commented Dec 7, 2023 at 23:55

0

You must log in to answer this question.

Browse other questions tagged .