I've been noticing some issues with my Mac lately and decided to repair permissions (with Disk Utility). However, after getting through a few files I am presented with:

Open error 1: “Operation not permitted” on usr/sbin/systemsetup

I've never encountered this before, so wanted to check if this is serious and how I might be able to rectify it.

Another issue, that may or may not be related, is that the System Information application is unable to gather any information about my machine. I am only presented with There was an error while gathering this information.

Any help would be greatly appreciated! I am running 10.7.3.


Unfortunately, I was unable to determine the cause of either of these errors. I tried repairing permissions after booting from a secondary partition with no luck. However, System Information did report the proper information when booting from this secondary partition. Eventually, I decided to reinstall Lion on my main partition, which resolved all issues.

  • how are you repairing permissions, through Recovery mode, a third party app, or directly inside your installation of Lion?
    – Stu Wilson
    Mar 30, 2012 at 7:17
  • Sorry, through Disk Utility within my Lion installation.
    – Jon
    Mar 30, 2012 at 12:36

1 Answer 1


It's possible that this is a message that you can safely ignore.

There is an Apple KB article for OSX versions 10.6 and below that itemises those error messages that can be ignored, however that message is not in the list. I cannot find an updated KB article for 10.7.

If the message does concern you, I'd suggest you reboot and hold down the Option key, you can then enter into Lion's Recovery mode from the menu shown and see if that does the trick.

  • I booted from a different partition and tried repairing permissions again with no luck. However, the System Information application did report proper information. As such, I decided to reinstall Lion on my main partition, which fixed the issue.
    – Jon
    Apr 19, 2012 at 15:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .