0

Since Sonoma and similar versions it is no longer possible to delete TimeMachine Backups in the TimeMachine Browser directly, I think it was Mavericks or so, this was the last time possible.

I tried everything by

sudo tmutil …

the … stand for hundreds of tries.

I gave up with

% sudo tmutil delete -p /Volumes/.timemachine/DF1238C8-A0F6-4DCE-89A3-5F206A8CD709/2021-07-19-145612.backup/2021-07-19-145612.backup/Macintosh\ HD\ -\ Data /Volumes/.timemachine/DF1238C8-A0F6-4DCE-89A3-5F206A8CD709/2021-07-19-145612.backup/2021-07-19-145612.backup/Macintosh HD - Data: Invalid deletion target (error 22)
Total deleted: Zero KB

The long path after the -p you get dragging and dropping the folder to Terminal.

how to delete or compact timemachine backups for one of the single users?

To be more precise, is there a possibility to compact or manually delete old TimeMachine backups from one of the Users?

7
  • 1
    TBH, I'd recommend treating TM like a black box, with no configurable options whatsoever. Messing with it usually causes problems.
    – benwiggy
    Dec 3, 2023 at 13:36
  • Thanks Ben, that's what I'm normally doing. Somehow the normally automatic deletion of older backup fails. That for, I'm looking for alternative solutions. On the one hand, TM is amazing but the lack of tools for e.g. migrating it to larger disks, like important other basic maintenance functionality is a total failure/design flaw. The man page of tmutil contains unfortunately also no examples, that's pretty bad.
    – Roland
    Dec 3, 2023 at 15:16
  • Why not copy the files you need to a new place and then delete the entire snapshot interval that needs deleting? The structure on APFS is new since it takes snapshots and works very hard to not allow people to go in and surgically alter parts of a backup.
    – bmike
    Dec 3, 2023 at 17:49
  • When you say "the automatic deletion of older backups fails", do you mean when the drive is full, or something else?
    – benwiggy
    Dec 3, 2023 at 19:25
  • The tmutil command should be sudo tmutil delete -d /Volumes/<TMVolume> -t <date-time> where TMVolume is that name of the volume containing your TM backups and date-time is that name of the particular snapshot you want to delete. It deletes whole snapshot. You can't delete a folder within it.
    – Gilby
    Dec 3, 2023 at 21:49

1 Answer 1

3

You can no longer modify within a backup. You can delete an entire backup by selecting the backup in Finder and right clicking it to delete it. You can also delete backups in Disk Utility and with the command line.

However the individual backups are now fully immutable because they are backed by File System level disk snapshots.

5
  • Could add to your first para that entire backup snapshots can be deleted in Disk Utility or using tmutil.
    – Gilby
    Dec 3, 2023 at 21:50
  • @Ezekial Just wanting to confirm... for deleting backups with the Finder, do you mean: right clicking it and selecting "Move to Trash", to delete it? I ask in part because I don't believe that'd be as thorough as using tmutil with the delete verb. The latter I believe would delete right away while the former only once the trash was emptied. Dec 17, 2023 at 16:11
  • I believe you'll see a time machine specific UI after doing that
    – Ezekiel
    Dec 17, 2023 at 16:16
  • @Ezekiel interesting! Just tried it now myself. Found that Finder shows popup asking "Are you sure you want to delete... This item will be deleted immediately.". So looks like it is immediate. I don't see anything any more Time Machine specific however with using Finder to delete the backup. Was there more you're seeing? A difference from tmutil delete I'm seeing is the com.apple.backupd.SnapshotCompletionDate attribute isn't being removed on the backup shortly after starting. But that's insignificant AFAIK. Dec 17, 2023 at 16:33
  • @LouisLangholtz Hmm, it appears I've misremembered. I remember it saying "Delete Backup" - but that being said, doing it through Finder in that manner should be perfectly effective/safe
    – Ezekiel
    Dec 17, 2023 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .