2

Since upgrading to iOS 17, I've noticed I'm no longer able to visit my home server from my home network when in Private Browsing Mode in Safari.

I'm fairly sure that the issue is that Safari is doing DNS lookups differently in Private Browsing Mode. The server I'm trying to connect to (call it www.example.com) has a private IP address on my home network. My router (which has a public IP address), is configured to port-forward port 443 from the public IP to my home server, so I can access it when I'm not home. However, port forwarding doesn't work for clients on the home network.

Because of that, my router (which provides DNS for my home network) is configured to return the server's private IP address for www.example.com, instead of the public IP address which is returned by looking up www.example.com in the public DNS. Therefore, clients on my home network trying to connect to https://www.example.com use the private IP address, and everything works.

This all worked fine on iOS 16. On iOS 17, https://www.example.com works fine in normal browsing mode. But in Private Browsing Mode, it appears to be trying to use my public IP address instead of the private address. I can tell because I get a bad certificate warning, and the certificate is the one my router uses for its management console.

What DNS servers does Private Browsing Mode use, and is there a setting I can change to make it use the network's default DNS instead?

I have noticed that if I use a hostname that is not found in the public DNS, then it does seem to fall back to my network's DNS server. But that's not really convenient for my use case. I want to be able to access the server at home or away using the same hostname.

2
  • 1
    Are you able to reproduce this behaviour in Safari on a Mac (and, what macOS and Safari versions?). Also, do you have Private Relay enabled, and is Limit IP Address Tracking enabled in the connection on the phone? Same questions on the Mac.
    – Harv
    Commented Nov 30, 2023 at 0:00
  • I don't have a Mac to test with.
    – cjm
    Commented Dec 17, 2023 at 6:30

1 Answer 1

1

Turn off “Advanced Tracking and Fingerprinting Protection” in Safari’s advanced settings, and don’t use the iCloud Private Relay.

1
  • This is it. "Advanced Tracking and Fingerprinting Protection” was set to Private Browsing. Changing it to Off makes it use standard DNS.
    – cjm
    Commented Dec 17, 2023 at 6:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .