0

I'm trying to update my MBP 2017 (A1708) from Big Sur to Ventura running the default update menu. It seems to work fine: it reboots several times, but when it finally boots to the login screen I still have the Big Sur without any error message.

I've tried resetting SMC and NVRAM and running the update from the safe mode still without any result.

The only thing my MBP differs from the stock one is the third-party SSD installed via the adaptor but it never caused any problems before.

Is there any way to fix it apart from running system recovery (I'm afraid of loosing my files)?

Here are the ways I've ran the update.

apps settings

5
  • Usually Ventura is installed by running the installer. Which default update menu are you referring to?
    – nohillside
    Commented Nov 25, 2023 at 11:52
  • I've tried going by System preferences and just running the installer from the apps without any result (maybe I've misnamed it, I'm running MacOS not in English)
    – Roman
    Commented Nov 25, 2023 at 12:41
  • Please add a screen shot from system preferences showing the installer you run.
    – nohillside
    Commented Nov 25, 2023 at 12:48
  • You have a backup of your files, don't you? You should be doing that before worrying about upgrading the OS. Commented Nov 25, 2023 at 15:22
  • I do backups of the important stuff but I'm still afraid.
    – Roman
    Commented Nov 25, 2023 at 21:07

1 Answer 1

1

Looks like it was caused by a non-apple SSD as I got an error "A required firmware update could not be installed" while trying to update the MacOS from safe-mode.

I've solved this problem by manually upgrading the firmware following the instruction: https://iboysoft.com/howto/a-required-firmware-update-could-not-be-installed.html

UPD: my mac is now booting very slowly (~15 min)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .