0

TL;DR

Sometime between 11/17 & 11/20, I became unable to place my nearly daily FaceTime call to my parents' iPad. Spent all day with Apple Support yesterday on this with no success. My parents' iPad is maxed out at 12.5.7, which according to the advisor, is incompatible with recent server upgrades. When I place a call using their Apple ID (not associated with a phone number), their iPad never rings & never shows a missed call. When they call my iPad, mine never rings in any case, the setting of "allow calls from" during "do not disturb" doesn't even show any notification of an incoming call, and on both iPads, the auto-answer setting (even without DND) stopped working.

The long version

I spent all day off and on yesterday with Apple support, debugging a new problem that popped up with Facetime sometime between 11/17/2023 and 11/20/2023 (inconveniently, right before Thanksgiving).

Background: when the pandemic lockdown happened, I created what I refer to as a "Facetime portal" to keep my elderly parents company while I worked. I blogged about the details of the setup, but essentially, I'd created secondary iCloud accounts, set up each iPad to only accept calls from known callers, and turned on auto-answer. Everything has worked swimmingly, aside from a few minor hiccups, between that time in 2020 and this past Friday. I created a simple shortcut on each iPad so that either of us could start the portal with a single tap (all it does it place a facetime call to the other party). It would place the call, each party would briefly hear a ring (both outgoing and incoming) and you would see yourself first and then the callee a second later, as the other device would immediately answer.

The problem: When I attempted to start the portal (as I have done almost every other day since 2020), I got this innocuous (but unusual/atypical) message:

caller ID

After tapping OK, I then got this error message:

choose another phone or email

And the call would never go through. My parents were never notified by their iPad that any sort of call was coming in. After the first occurrence of the message/error, I no longer see those messages when I try to initiate a call.

We also tried it the other way around. I had them place the FaceTime call to my iPad. I could see the incoming call, but the auto-answer would not pick up. I had to tap twice: once to "accept the invite" and then: to "join" the call.

The behavior of the outgoing call was different on my end too. Usually when I place the call, I would see myself fill the screen and would hear an outgoing "ringing" sound, then once it connected, my image would shrink to the corner and my parents' feed would fill the rest of the screen. Now however, instead of seeing myself and hearing a "ring", a generic green icon comes up with the message "invite sent", there is no sound, and it never goes through.

According to Apple support, there was apparently an update to Apple's server that routes FaceTime calls, and the problem is that my parents' iPad is maxed out at iOS 12.5.7. Mine WAS on 16.3.1, but as a part of the debug process, I updated to 16.7.2 (but still see the same behavior).

The advisor was unable to figure out how to resolve the issue, but he believed that the old iPad became too far out of date with Apple's servers. He did suggest a way to try and fuss with it to try and get it to start working, and that was to log out and back in to iCloud on both devices, though we haven't tried that yet. I also saw a youtube video posted 4 days ago that references the error message that suggests offloading the FaceTime app and doing a hard-restart - but I haven't tried that yet either.

A more drastic solution would be for my parents to get a new iPad, but the problem there is, upon iOS 14, auto-answer started requiring the device to be unlocked (and according to an Apple Advisor at the time, the intention was that it was to work with FaceID, which neither of our iPads have, thus, you must touch the iPad to answer the call). Prior to that (in iOS 13), auto-answer would still work, regardless of the device being locked. I had an older iPad Mini at the time, and to get around that, I turned off auto-lock, however that caused the screen to precipitously deteriorate, since it was on 24/7. And since getting my new iPad, I have just been the one to start the portal, since mine won't auto-answer when the screen is dark.

Aside from suggesting possible solutions for the 2 current devices to make the FaceTime calls both go through and auto-answer, I would also like to ask if anyone can confirm if there is a way to have auto-answer work (without having to touch the iPad regardless of lock) in the latest iPadOS. (I can't imagine how that's not an option given the purpose of auto-answer is to allow people who are for example, quadriplegics, to be able to take phone calls.)

UPDATE

I was reviewing my blog. I'd forgotten that part of my setup was to create a contact card group and then setup "Do not disturb"/"Focus" to allow calls from that group (purpose-being so that the iPad will only auto-answer callers in that group). I hadn't had focus turned on on my (new) iPad, so I turned it on and set the "allow calls from" to the group containing the contact card. When that is set, despite the "allow calls from" setting, my iPad does not ring or give any sign a call is coming in until after the call attempt has ended (in which case, the FaceTime app icon gets a badge about a missed call).

I confirmed that my parents' iPad was still set to DND and that the group was still set to be allowed and contained the contact card. So we also tested turning off DND on their iPad running iPadOS 12.5.7. No FaceTime call (me -> parents) goes through and no missed call appears in FaceTime.

8
  • Just tried again today, both ways. I don't know what happens on my parents' iPad, but on my iPad, I get no notification or anything during. I'd texted my parents to start the portal. Eventually, a red badge appeared on my FaceTime icon, and opening it showed a missed call. This is different from yesterday. See my update at the bottom (which I will add in a minute).
    – hepcat72
    Nov 21, 2023 at 19:32
  • 1
    Wow! Please put in an answer once you’ve got clarity and know what the skinny was. Great troubleshooting details
    – bmike
    Nov 22, 2023 at 15:21
  • I have a feeling this will really only be (partially) solved via an update to devices currently maxed out at 12.5.7, to allow them to receive calls. What I haven't tested yet was 1. switch to starting calls from a phone number (which we couldn't do), 2. log out and in of the iCloud account, and 3. offload FaceTime and hard-reboot each device (suggested by a YouTube video about the error message). I would accept a solution that at least allowed me to place a call to my parents, even if "allow calls from" in DND, auto-answer, and ringing still didn't work.
    – hepcat72
    Nov 22, 2023 at 15:35
  • Another minor issue I did not mention, is that you used to (in iOS 13?) be able to set the "delay before auto-answering" to 0 seconds. My parents can still do that, but on 16.3.1 (to 16.7.2), you cannot set it shorter than 3 seconds. Prior to 16, the min had changed to 1 second, and in 16.3.1, I still had 1s (a legacy setting). When I tried to change it to 0, it popped up to 3 and I could not get it back to 1. I would have cancelled to keep the 1, but at that point, I was more interested in getting it to auto-answer, period, so I let it change to 3.
    – hepcat72
    Nov 22, 2023 at 15:49
  • Visiting for Thanksgiving. Couldn't really debug effectively remotely because I couldn't see my parents' screen and did not trust their description. Turned out to be an easy fix. All I had to do was log out of my iCloud account and back in. Then it started working. Sigh. Not sure what caused the issue in the first place and I'm surprised that wasn't one of the first debug suggestions by the senior advisor.
    – hepcat72
    Nov 25, 2023 at 17:36

1 Answer 1

0

I cannot explain why this worked, but the solution was to log out of iCloud account on calling device.^

I can point out a few extra-ordinary conditions where this issue popped up:

  1. Calling device:
    • iOS: 16.x (specifically 16.3.1 to 16.7.2 or later)
    • Initiate calls from iCloud email address (not associated with a phone number)
  2. Receiving device:
    • iOS: old iPad maxed out at 12.5.7
    • iCloud account not associated with a phone number
    • Do not disturb: on or off (before focus was introduced) with:
      • Allow calls from set to a contact group containing calling device's iCloud ID

The advisor suggested this to "try", but he definitely didn't seem to think it would work. It was the first thing I tried after having spent significant time with an Apple Support senior advisor.

^ - There were other steps I took before logging out and back into iCloud that may or may not be required to get this to work:

  1. Update to iOS 16.7.2 (iOS 17 was available, but I didn't update to that)
  2. Force-restart the device
  3. I had also turned off and on a bunch of various settings during debugging, including (but not limited to) auto-answer, focus, allow calls from, the contact card I was calling, etc. - but none of those things fixed the issue until I logged out/in from/to iCloud

It's also notable that I was always able to successfully place facetime calls to other iCloud accounts/phone-numbers - just not the iPad on 12.5.7. And, I should also point out that an old iPad Mini I have still on iOS 14.x was able to call the iOS 12.5.7 iPad without issue - it never stopped working, and was logged into the same iCloud account.

1
  • Sorry for the late update. Been pretty busy.
    – hepcat72
    Dec 4, 2023 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .