0

I am trying to establish a new tunnel on ISL Light app from ISL Online. I have an account already and on when I log in, in the Computers window I can access a remote server that I am assigned to have access to. The thing is I am trying to connect to it with my MacBook Pro M2 2022 but I am not able to do so.

I have tried with different commands as the SSH default schema as follows:

  • osascript -e 'tell application "Terminal" to do script "ssh -p {PORT} myusername@localhost"'
    This is the main one I have tried, changing app for application, and neither of those works. The thing with this one is that the tunnel is opened I suppose because on ISL Light I can see that I have an opened connection to the remote server but the Terminal app does not open so I cannot access via SSH to the remote server.
  • osascript -e 'tell app "Terminal" to do script "ssh -p {PORT} myusername@localhost" in front window'
    Looking for possible solutions I found this but it does not work either.
  • osascript -e 'tell application "Terminal" to activate'
    This one gave an error that the parameter {PORT} was missing. I would like to know if there is a problem with compatibility with ISL Light or with my command to open the terminal on Mac OS. I have contacted the ISL Light support center but got nothing solved.
2
  • Why do you want to use osascript here? Can't you just open Terminal manually and run ssh ...? Also, if you need this for work, aren't you entitled to support by ISL?
    – nohillside
    Nov 21, 2023 at 10:03
  • Also, after looking at some of the videos from ISL: this seems to be a remote desktop solution, what do you need ssh for here?
    – nohillside
    Nov 21, 2023 at 10:10

0

You must log in to answer this question.

Browse other questions tagged .