0

I was trying to adapt the accepted answer to this question. How to integrate FileMerge.app into Finder?

I'm on a mac with macOS Sonoma version 14.1.1. Unfortunately I get the following error message.

enter image description here

Doesn't it work as described in the linked answer? May be because it is 2 years old and things have changed? How can I make it work? The Idea remains the same, i.e my goal is to select two text files in finder and compare them.

5
  • The error message is saying opendiff is in Xcode, so If you don't have that installed something else will need to be used.
    – red_menace
    Commented Nov 20, 2023 at 19:53
  • I have xcode installed. May be it has some issues. I'll try to uninstall it and reinstall
    – Eritrean
    Commented Nov 20, 2023 at 20:08
  • @red_menace I have re-installed xcode. Every thing looks fine from that perspective. But the same error remains. Any Ideas?
    – Eritrean
    Commented Nov 20, 2023 at 20:23
  • You can try running Xcode or use the command line tool xcode-select to switch the developer directory that is being used.
    – red_menace
    Commented Nov 20, 2023 at 20:45
  • Can you try to use $(xcode-select -p)/usr/bin/opendiff instead of just opendiff in Automator? Commented Nov 20, 2023 at 21:03

0

You must log in to answer this question.

Browse other questions tagged .