0

I just upgraded to the macOS Sonoma because I need to update my Xcode. Now I notice that when multiple Bluetooth devices are connected to my Macbook the Bluetooth headphone/speaker sounds weird. The sound is being cut off and sounds like "sped up" than usual. This happens when my keyboard and mouse are also connected to the Macbook via Bluetooth (that means three Bluetooth devices connected at the same time). When I disconnect either the keyboard or mouse the headphone/speaker works fine.

I didn't have this issue before upgrading to Sonoma. Does anyone have this issue and is able to resolve it?

I already tried restarting the Macbook and re-pairing the Bluetooth devices including the headphone and speaker but still, the issue persists.

Below is screenshot of Activity Monitor, as requested. enter image description here

3
  • Check the CPU usage of bluetoothd in activity monitor
    – Ruskes
    Nov 20, 2023 at 4:44
  • 1
    @Ruskes I don't know what should be the values or if they're not normal, so I attached the screenshot.
    – SquareBox
    Nov 20, 2023 at 7:33
  • It does not look to busy I have 1% with 2 devices, not audio
    – Ruskes
    Nov 20, 2023 at 18:34

2 Answers 2

0

I was curious, as I have suffered from this issue recently too, so I decided to take a packet trace of the bluetooth activity. I'm still studying the details, and I noticed three things.

I usually turn my audio headset on/off throughout the day as I enter/exit meetings. Recently, the mouse will have gaps in mouse movements, and the headset will have distorted audio. Turn off one or the other, and the issue goes away. Disconnect, forget hardware, re-pair, and still the issue. It's as if packets are lost.

(1) connected audio headset, "Role change - [the address of headset] LMP PDU Not Allowed" Events happen.

(2) later, ~1:358, "Configure Response - AVCTP - Failure - Unacceptable Parameters" appears.

(3) after opening Zoom, ~1:06:118, "Suspend: Signal," followed by an OS response of "First non-flushable Packe of Higher Layer Message (Start of An L2CAP Paket" and then a "Suspend: Acceept-Response", this happened just when I heard audio distortion.

This particular Mac is the first Mac I've had any other OS, though now that I know what I am looking for, I'll see if this happens on my other Macs, too. I will send this info to the manufacturer of the blue-tooth headset and Apple. However, if anyone wants to dive into the details, I can put them here, too.

It would be interesting if your system encountered the same issue. Can you take a Bluetooth packet trace?

2
  • What application did you use for Bluetooth packet tracing? I tried PacketLogger from Xcode but I don't have any idea with the logs being displayed.
    – SquareBox
    Nov 28, 2023 at 0:08
  • So I checked again the PacketLogger from Xcode and found the same logs: Configure Response - AVCTP - Failure - Unacceptable Parameters
    – SquareBox
    Nov 29, 2023 at 5:56
0

Seems still to be an issue even with the latest Ventura (14.1.2). Neither the headset vendor or Apple has replied back. The folks at Apple mentioned they were escalating the matter and that it would take a while.

enter image description here

I've changed my work style to work around the bug, as I go into mtgs without the headset. I have yet to find my AirPods to see if they also have the same registration issue. I also have not dove into the protocol to see why the headset would need the various Role Change styles and if there is an alternative. I know this, though; today, my Magic Mouse ran out of batteries, and my other mouse is wired - now I have another workaround.

Sam

Ps, shoot, I don't have enough reputation :) with stackexchange to be able to comment on my own reply. Sorry, everyone for not following the norm.

pps, (comment too long, so adding here) I found something weird about this problem. I use the system primarily for VMware guest OS efforts. I wondered, what if I attach the headset to the guest and use the AirPods for the host only? Of course, it didn't work as planned, but it did adjust the problem. I removed the headset from the host. Then I went into the guestOS and paired the headset to the guestOS. Everything worked great, even in the host, which, oddly, VMware paired the headset in the host and shared with the guestsOS. I played music on the host and moved the mouse without problems.

Then the unexpected thing happened. I stopped the guestOS, retried the headset in the host (macOS Sonoma 14.1.2), and found that the headset wasn't paired in the host (connection timeouts, etc., as it's passing through to the guest for negotiation). Good cause, that's what I wanted - but with respect to the problem (mouse jitter and poor audio from the headset), it's weird. When the headset is negotiated with the guestOS properly (even with the errors in Bluetooth configuration negotiation), the audio and mouse behave beautifully in both the host and guestOS. Stop VMware, remove the device, re-pair to the host, and the mouse jitter/poor audio returns.

If that's not weird, I don't know what is. I found the solution :) ... either pay VMware and get the headset accidentally working in the host, or pay Apple and use AirPods. :) IDK, after all the stuff I dealt with between Apple and the headset vendor, it's funny that a third company somehow enables a fix :) ... right? go figure, eh?

2
  • Same for me, I just decided to wired my speakers and for some reason my headphone and AirPods works fine for calls. But when I use them for music the issue would still show up. I also updated to 14.1.2 and still have the problem.
    – SquareBox
    Dec 4, 2023 at 7:01
  • Using AirPod, didn't have any issues. There were no role-change requests and had encryption. So, something about the role change, which is rejected, triggers the mouse/headset packet conflict with the 'jumpy' mouse and poor audio experience. Workaround: AirPods. Next step for me: what way does the role-change have to be configured to be accepted, and see if that stops the packet collision issue. ps, at least I have enough rep to add comments now :).
    – Sam
    Dec 8, 2023 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .