0

My internal SATA SSD is formatted as APFS and I am running High Sierra on it. I want to use open core patcher to install Big Sur on a separate APFS partition (I heard there were problems when having both in the same container), but when I use Disk Utility to try and partition the disk, it comes out with an error (see pics). I really don't want to erase the disk, so if there is any way to do this without an erase, any help is appreciated! (tried in recovery mode and same problem). I am using an iMac (21.5-inch, Mid 2011).

apfs volume

Partitioning

Getting this error

2 Answers 2

1

I got it working by erasing the disk with the high sierra recovery, re-installing MacOS, and then partitioning. Now I have big sur and high sierra working perfectly together!

0

I have an iMac (21.5-inch, Mid 2011) running macOS High Sierra, version 10.13.6. My internal drive is a 1 TB HDD with a macOS High Sierra, Ubuntu Linux and Windows 11 triple boot arrangement. I can verify your procedure using a 1 TB sparse disk image.

I performed the same partitioning operation on the disk image as you did on your internal SSD. Below is the result.

enter image description here

Since the operation was successful, your idea of creating a second APFS container from an existing APFS container is valid under High Sierra. The details are given below.

Running operation 1 of 1: Add “OpenCoreMacOS” by splitting “High Sierra HD”…
Aligning shrink delta to 249,947,779,072 bytes and targeting a new physical store size of 749,842,485,248 bytes
Determined the minimum size for the targeted physical store of this APFS Container to be 224,772,096 bytes
Resizing APFS Container designated by APFS Container Reference disk3
The specific APFS Physical Store being resized is disk2s2
Verifying storage system
Performing fsck_apfs -n -x /dev/disk2s2
Checking volume.
Checking the container superblock.
Checking the space manager.
Checking the object map.
Checking the APFS volume superblock.
Checking the object map.
Checking the fsroot tree.
Checking the snapshot metadata tree.
Checking the extent ref tree.
Checking the snapshots.
Verifying allocated space.
The volume /dev/disk2s2 appears to be OK.
Storage system check exit code is 0.
Shrinking APFS Physical Store disk2s2 from 999,790,264,320 to 749,842,485,248 bytes
Shrinking APFS data structures
Shrinking partition
Modifying partition map
Initialized /dev/rdisk2s3 as a 233 GB case-insensitive HFS Plus volume with a 24576k journal

Mounting disk
Creating a new empty APFS Container
Unmounting Volumes
Switching disk2s3 to APFS
Creating APFS Container
Created new APFS Container disk4
Preparing to add APFS Volume to APFS Container disk4
Creating APFS Volume
Created new APFS Volume disk4s1
Mounting APFS Volume
Setting volume permissions
Operation successful.

Your details show the following.

Volume superblock is invalid.
The volume /dev/disk0s2/ could not be verified completely.
Storage system check exit code is 0.

Since the exit code was 0, the Disk Utility proceeded with the partitioning operation and failed. I assume the failure was related to the superblock being invalid. You could try running First Aid on the SHGS31-1000GS-2 media, the disk1 container and/or the High Sierra HD volume. If this does not fix the problem, then you are out of luck.

BTW, the Disk Utility under High Sierra often shows the incorrect results after performing an operation. You can see this in the above image posted to this answer. After quitting and opening the Disk Utility, the correct results appear, as shown in the images below.

enter image description here

enter image description here

5
  • I ran first aid on both to no avail. Any suggestions?
    – Luke M
    Nov 15, 2023 at 20:24
  • I have no other suggestions, unless the APFS container was create using a newer release of macOS or a newer release of macOS was installed to this container in the past. In such cases, you would need to boot from the newer macOS (or newer macOS Recovery) in order to shrink the existing APFS container. Nov 15, 2023 at 21:22
  • It was, but the newer macos (ventura) was deleted. any other way?
    – Luke M
    Nov 15, 2023 at 22:26
  • You have stated "I heard there were problems when having both in the same container". However, Apple has stated this is OK to do. I once had Mojave and Big Sur installed in the same container on a 2018 Mac mini. If the problem with High Sierra resizing the container was because of a previous Ventura, then this may be a way to try. Nov 17, 2023 at 18:27
  • When I installed High Sierra, the volume with Ventura became inaccessible. Also see this thread: forums.macrumors.com/threads/…
    – Luke M
    Nov 20, 2023 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .