0

I have a MacBook with 500GB internal storage. I have a 1TB external SSD.

I use iCloud Photos, and have the library on the external drive. It downloads the originals.

First the situation was this:

Mac:

  • 350GB free space left

External drive:

  • Photos Library: 600GB
  • Folder with other files: 150GB
  • Available space (according to 'Get Info'): 200GB

Then, because the external SSD was starting to get fuller, I moved the folder with other files (150GB) to the Mac, and deleted it from the external drive. I also emptied the trash while the drive was connected. After that I made some metadata changes to photos in the Photos Library, and I also added 1.5GB of photos.

Now the situation is this:

Mac:

  • Folder with other files: 150GB
  • 200GB free space left

External drive:

  • Photos Library: 610GB
  • Available space on the drive (according to 'Get Info'): 10GB

Photos says "Synching paused. Not enough local space."

So, me wanting to make more space on the external drive (plus have this folder always available on my Mac), caused Photos to stop synching because there is not enough space. The Photo's Library (Get Info) is 610GB. There are no other files on the drive, and all hidden folders are a few KB or MB.

What is taking 380GB of the space? Is it Photos, if so, why it doesn't show that?

How do I get back the space without creating a new Photos library that downloads all photos from iCloud? Or is my only option buying a 2TB drive now?

Also, I have the 2TB iCloud subscription, of which over 1TB is still available. The used space is taken by Photos Library and a few hundred GB of other files.

Thanks in advance. If more info is needed, let me know.

EDIT: I scanned the drive with GrandPerspective. There is 310GB "miscellaneous used space"

Also, my MacOS version is Ventura 13.5. Photos version is 8.0.

2
  • Did you empty your trash (with the drive connected)?
    – X_841
    Nov 15, 2023 at 12:08
  • Yes, as described in the question. The trash looks empty, and the hidden Trashes folder on the drive is 0kb.
    – Jeroen
    Nov 15, 2023 at 12:45

1 Answer 1

0

So the external drive has 10GB of free space reported (I connected the drive to different machines to confirm this).

When I tried to copy a 20GB folder to it (which in theory should give an error that it doesn’t fit), the free space quickly started increasing to the expected 390GB (minus 20GB for the copied folder)

I’m not sure what’s going on; whether the drive is breaking or a software issue, but it’s solved now. Let’s hope the photo library is safe on the drive.

1
  • 1
    My guess, is snapshots created by your backup software.
    – Gilby
    Nov 15, 2023 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .