1

How do I install High Sierra on APFS external hard drives?

I only want to boot High Sierra off the drive on RARE occasions, for testing purposes. I don't care how slow it is, bad performance, etc.. The majority of the time, the drive would be home to an automated backup copy (SuperDuper).

I've been trying to install High Sierra for days now, and the installation always fails to continue after restart. I can't figure it out. I selected the wrong drive on one attempt and now I have a fully functional bootable APFS High Sierra thumb drive, but the external hard drive install still eludes me.

If this can't be done on external APFS HDDs, I would honestly expect the High Sierra installer to stop me when I try, give an error message to explain, and suggest a better option.

I'm happy to edit with any requested info. I'm just not sure what's relevant.

11
  • I didn't think High Sierra would install to an APFS drive, only to HFS+, which it would then convert itself as part of the installation process.
    – Tetsujin
    Commented Nov 7, 2023 at 8:26
  • @Tetsujin, I SWEAR I did it to an APFS external HDD just a few weeks ago, but I needed to re-format, so I gave it up. Presently, I have installed successfully to APFS internal SSD, and to APFS thumb drive (I did another one on purpose, out of curiosity).
    – sbimos
    Commented Nov 7, 2023 at 16:26
  • You could perhaps clone the working thumb drive to the HD? Up to Mojave, that's a valid method - it got tougher since. [I've never used Super Duper, but Carbon Copy Cloner can definitely do it.]
    – Tetsujin
    Commented Nov 7, 2023 at 17:43
  • @Tetsujin, that's a very good idea. I had it too and tried 4 times, but it would never boot. I tried thumb drive SuperDupered into HDD, and thumb drive manually copied into HDD (yes, the invisible files too). SuperDuper copy showed up right away in Startup Disk, but no boot. Manual copy didn't boot either. First Aid on both, retry, still no boots. I also tried superduper and manual copy from an APFS SSD installed High Sierra that was fresh (never booted or set up) to HDD, and neither of those would boot either. Also First Aided, still no luck
    – sbimos
    Commented Nov 7, 2023 at 19:12
  • 1
    @Tetsujin I used to use CCC. I can't remember why I switched to SuperDuper. I don't have issues with either. Regarding my failing installs, the cloning was just a final attempt after I ran out of ideas to try. I don't think SuperDuper is the issue, as I've tried countless methods of installing, plus I've varied the destination a few ways, to see if that was the cause. I did TONS of testing, but no answer yet.
    – sbimos
    Commented Nov 8, 2023 at 1:56

0

You must log in to answer this question.

Browse other questions tagged .