This issue affects all native text apps (Notes, TextEdit, and Mail). It does not affect Safari. Nor does it affect Notes and Mail on iPadOS (17.1) (that's still in the UK).

Only autocorrect works in Pages (I can't recall whether autocomplete is supposed to as I've not had a reason to use it since autocomplete was added to macOS).

I can't recall when I first noticed it, but it's doing my head in now. Like I said, I'm in the UK; everywhere in Settings which needs to be set to British/UK English is set to British/UK English.

So words we spell with an 's' it autocompletes with the 'z' spelling; words which end -our in UK English. Autocomplete will complete with the '-or' American suffix. I have to spellcheck them back to the correct spelling and this is getting a little old now (autocorrect is still using the correct version of English). When you're as active in political circles as I am, having to constantly recorrect the spelling of 'Labour', for example, is somewhat tedious (I'm not in Australia - but I often wish I was).

I've not, wittingly, done anything that would cause this - it's just too bizarre (see explanatory screenshots) I can't post to Apple's forum as I had the phone I used for 2FA stolen. Apple support is useless; wants me to call them - even if I did have a phone, I only ever used it for texts/WhatsApp as I struggle with speaking and Apple has no means, apparently, to escalate a chat-box 'call'. If I want any further assistance, I have to speak).

I'm on the verge of reinstalling macOS, but that seems like a sledgehammer. I have tried creating a new account and using that account in safe mode but, obviously, it's still broken.

Is this a bug...? I'm just trying to recall if I had an issue with autocomplete prior to 14.1. It seems so bizarre, that I can only think that it is.

Can anyone suggest any workarounds...? I would rather not have to turn autocomplete off.

If you're in a country that uses UK/Commonwealth English (which, as far as I know, are (virtually) identical) or have a Mac that you're using with UK English - are you having a similar issue...?

I'm autistic and this is beginning to really stress me out now (as is that fact that Finder find appears to be disabled, but I'll save that for another post)

Screenshot of text showing autocorrect according to UK English

Screenshot of text after autocorrect showing US English spelling


1 Answer 1


Firstly, there absolutely no point in reinstalling the OS. This is most likely a settings issue, and no amount reinstalling will change it. (Reinstalling the OS is massively overrated as a fix.)

Next, check that the language is correct in System Settings:

Your "Preferred Language" should have "English (UK)" at the top. enter image description here

Make sure that no Applications have customised settings.

enter image description here

You could also try setting System Settings > Keyboard > Text Input > Edit > Spelling to British, rather than Automatic. For each app go to Edit > Spelling and Grammar > Show Spelling and Grammar and make sure the Dictionary is set to UK English and not Automatic.

enter image description here

You could also try setting the language on the command line:

defaults write -g NSPreferredSpellServerLanguage "en_GB"

It's curous that this affects brand new user accounts, too. Perhaps something has been set in /Library/Preferences (the root level folder, not the user account folder). You could search for plist files relating to spelling there.

I like to mention that British English used to favour -ize until the early 90s, except for a small list of words that always took -ise and never -ize. For some reason, a 'simplification' appears to have been made (when spellcheckers first appeared), so that -ise is now the default. The OED still shows -ize first.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .