0

I have a brand new 256Gb SanDisk Micro SD card and I'm not being able to read/use in my Mac through the internal SD Card reader slot (I don't have an external card reader to try this option).

The card was working at the very beginning, but after a format (or something I don't remember) it become not recognized by SO.

I've tried "Disk Utility" format (Erase) with all partition types (ExtFAT, Mac OS Extended, etc) to no avail. It formats the card successfully, but then it is still unseen by "Finder".

I've also tried "First Aid" in "Disk Utility" to no avail too, it does the recovery with no errors, but the card continue to be unseen, so I cannot write to it.

I've been reading How to fix broken GPT, GUID and unmountable, no type volumes?, but I'm currently stuck.

If I do (in Terminal):

sudo gpt -v show /dev/disk4

The response is:

gpt show: /dev/disk4: mediasize=255869321216; sectorsize=512; blocks=499744768
      start       size  index  contents
          0          1         MBR
          1      65535         
      65536  499679232      1  MBR part 7

Any help in order to make my SD Card to be recognized/work? I'd prefer to use ExtFAT so it can then be read in Windows as well as in my Android mobile.

Edit 1: After @David Anderson suggestion.

diskutil erasedisk exfat MyExFAT mbr disk4
Started erase on disk4
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk4s1 as ExFAT with name MyExFAT
Reformatting existing ExFAT volume
Volume name      : MyExFAT
Partition offset : 65536 sectors (33554432 bytes)
Volume size      : 499679232 sectors (255835766784 bytes)
Bytes per sector : 512
Bytes per cluster: 262144
FAT offset       : 32768 sectors (16777216 bytes)
# FAT sectors    : 7680
Number of FATs   : 1
Cluster offset   : 65536 sectors (33554432 bytes)
# Clusters       : 975808
Volume Serial #  : 6ab00ea2
Bitmap start     : 2
Bitmap file size : 121976
Upcase start     : 3
Upcase file size : 5836
Root start       : 4
Mounting disk
Could not mount disk4s1 after erase
Finished erase on disk4
10
  • Theres a very comprehensive QA on this at SuperUser - superuser.com/questions/1125282/… which is well worth the read.
    – Tetsujin
    Commented Nov 1, 2023 at 20:05
  • Can you format it on your Windows machine and see what happens? (Assuming you have, or have access to, a Windows machine.)
    – IconDaemon
    Commented Nov 1, 2023 at 20:05
  • Have you got a camera you can try it in, and see if the camera will format it? Commented Nov 1, 2023 at 20:35
  • 1
    @Andy Griffiths the idea of the camera was good, didn't realize and I have a Nikon reflex. I'm trying, but now its been almost 5 minutes and the camera is still on "Formatting the card". Maybe this is because it's a 256Gb card, or maybe the camera software just got stuck, don't know. I'll wait some more time before turning the camera off, I wouldn't like to damage the card.
    – Krueger31
    Commented Nov 1, 2023 at 21:58
  • 1
    @Andy Griffiths, maybe the problem is my Nikon D7000 max sd card supported size is 128Gb, and it got stuck because of that... The weird thing is that the green light -which indicates writing is in progress- is still blinking.
    – Krueger31
    Commented Nov 1, 2023 at 22:04

0

You must log in to answer this question.

Browse other questions tagged .