I've got an iPhone 4, not quite sure which version of iOS, but I keep current.

Recently, I got an update for one of the apps, started it, and then for some reason it got stuck on "Waiting..." indefinitely. Another app later offered an upgrade, and when I accepted it got stuck on "Waiting...". This has been a few days now, with both 3G and wireless available, with no change.

The apps don't have the "delete" button when I touch and hold on them, and I tried deleting them in iTunes but after syncing my iPhone there was no visible change. (They're free apps, so deleting and reloading is a fine solution, but knowing how to kick-start the updater would be nice.) The App Store app simply tells me they've been updated.

Any suggestions?


I get that problem sometimes too on my iPhone 4, especially if I'm updating an app and I lose network coverage.

Here's what I'll usually do, either:

  • Sync with iTunes
  • Restart my phone by holding down the power and home buttons.

Either of those fixes the problem for me.

  • I think I beat you by a minute only because you went all fancy with formatting :D. – Jason Salaz Dec 5 '10 at 19:57
  • :-) I came here from StackOverflow, where they punish bad formatting with beatings. It's a hard habit to break! – glenstorey Dec 5 '10 at 20:13
  • SO is a bit of it's own world. Add to the fact that I'm not a programmer and it makes sense that I'm not nearly as active on it and haven't ingrained it's elitist ways into my habits :). – Jason Salaz Dec 6 '10 at 5:22
  • Does not work for me. – Lexible Nov 5 '16 at 22:19

This has been discussed in numerous threads in the Apple forums, but as of iOS 9.3.2, Apple do not yet seem to have fixed it. See this one for example:


Although rebooting your device sometimes fixes this problem, be careful as it may also completely wipe the app from your device, including all data.

Instead, the recommended way is simply to open the App Store app, visit the updates screen, and then stop and restart the update. I've had the update hang on me several times in a row, but it should eventually download and install.

I'm not sure, however, if this method is available for those with Automatic App Updates enabled, since I have mine set to manual.


Reboot it. I've seen this problem a small handful of times on my, and one other individual's, iPhone.

Not the answer you're looking for? Browse other questions tagged .