3

Title:

Spotlight Not Showing Core Applications on macOS Sonoma 14.0: How to Fix?

Problem Description:

I used to rely on Spotlight to quickly open Core Applications like Finder, Contacts,Photos, and Terminal. However, this functionality seems to have stopped working (potentially since the last update before Sonoma). I've noticed that even on iOS, the search feature helps me avoid the need to remember icon placements. Spotlight now seems to be excluding these system files in its search results.

EDIT:

All Applications stored in System/Applications are excluded from search. Even if there are some kind of "link" between the apps in the Macintosh HD/Applications and their original location in System/Applications. Also apps in System/Library/CoreServices are excluded as mentioned.

Search that Works

  • Safari (though it shoes a 'Alias' badge on the icon yet links back to the Application Folder when opening with Cmd + Enter)
  • All applications I added
  • All apps from AppStore: Numbers, Pages, etc.
  • Web Apps
  • System Settings
  • Single notes in the Notes app (but not the app itself)

Search that Doesn't Work

  • Utility Folder (Terminal, Disk Utility, Activity Monitor)
  • All native apps in Application Folder:
    • Photos, Messages, Mission Control, Notes, Reminders,

What I've Tried:

  • Re-Building all of Spotlight
  • Re-indexing User/Application, System Applications,
  • Adding and then removing the CoreServices folder from "Exclude in search" to force reindexing System/Library/CoreServices
  • Adding aliases to Finder into the HD/Applications folder
  • Rebooting in Safe Mode
  • Repair disk permissions
  • Uninstalling unnecessary apps that might interfere

Questions:

  1. Is anyone else experiencing this issue, or is it specific to my machine?
  2. Are there any safe workarounds or solutions?

Previous Research:

I've explored existing discussions but none seem to address this exact problem:

System Information and Installed Software:

  • MacOS Sonoma 14.0, MacMini M1 2020
  • Potential Interference:
    • CleanMyMac
    • Little Snitch
    • AdGuard
    • BetterTouchTool
    • SetApp
    • 1Password

I'm open to troubleshooting steps, like booting in Safe Mode or disabling extensions. Any advice is highly appreciated.


Tips for Solutions:

Suggestions from ChatGPT that I'm trying. None of them worked!

If your question doesn't get a timely answer, consider the following steps for self-troubleshooting:

  1. Safe Mode: Boot your computer in Safe Mode to check if the issue persists. This will disable all third-party extensions and isolate issues.

  2. Console Logs: Check console logs for any errors related to Spotlight to identify possible issues.

  3. Application-Specific Settings: Check if CleanMyMac or Little Snitch have settings that affect Spotlight's behavior.

  4. System Preferences: Go to System Preferences > Spotlight and verify the categories that are enabled for search.

  5. User Profile: Sometimes the user profile can be corrupt. Try logging into a different user account to see if Spotlight works as expected there.

2
  • 1
    Weirdly, the ChatGPT advice seems sound. I don't think this is a common experience with Sonoma, but it's still on the .0 release. Maybe see if the .1 (which should be out soon) improves anything. Also, I'd uninstall CleanMyMac. Largely unnecessary and can do just as much damage as it claims to prevent.
    – benwiggy
    Commented Oct 23, 2023 at 9:27
  • @benwiggy, thanks for the comment. I do believe CleanMyMac might have caused the corrupt index. I've used the software for many years and never had any problems that could like to it. So hopefully more people see this post if they are experiencing similar issues and can either uninstall it or use my solution below. Commented Oct 23, 2023 at 9:40

1 Answer 1

4

Solved


ChatGPT suggested it might be corrupt indexing. And offered a step-by-step solution via Terminal. This solved the problem for me. I had tried these from other sources.

  1. Adding and removing HD in System Settings → Privacy
  2. Deleting existing index via Terminal command: sudo mdutil -E /

Neither of the solutions above alone solved the problem. But the new commands ChatGPT suggested did fix it form me. Now Spotlight shows all applications from the System folder in the results.

Note: I've pasted this whole respons from ChatGPT offering both what have worked for others (and recommended by Apple Support) and the one that worked for me (check-marked ✔).

Solution


A corrupt Spotlight index could be the reason behind the issues you're facing. Unfortunately, macOS doesn't provide a direct way to check for a "corrupt" Spotlight index, but there are ways to rebuild it, which effectively removes the old, potentially corrupt, index and replaces it with a new one.

Option 1) ✅ Rebuilding Spotlight Index via Terminal:

  1. Open Terminal: You can find Terminal in Applications > Utilities or search for it using Spotlight (if it can find Terminal, that is).

  2. Disable Spotlight: Type the following command to disable Spotlight for the main volume (usually named "Macintosh HD"):

    sudo mdutil -i off /
    

    You'll be prompted to enter your password.

  3. Delete Existing Index: Type the following command to delete the existing index:

    sudo mdutil -E /
    
  4. Enable Spotlight: Finally, re-enable Spotlight indexing:

    sudo mdutil -i on /
    
  5. Check Status: Optionally, you can check the status of the indexing process with:

    mdutil -s /
    

Option 2) Rebuilding Spotlight Index via System Settings:

  1. Go to System Settings: Open it from the Dock or from Apple Menu > System Settings....

  2. Siri & Spotlight Settings: Click the button Spotlight Privacy... at the bottom.

  3. Add Drive to Privacy: Drag your hard drive (usually "Macintosh HD") into the Privacy window. This will stop Spotlight from indexing it.

  4. Remove Drive from Privacy: Remove the hard drive from the Privacy window. This will force Spotlight to re-index the drive.

After performing any of these sets of steps, your computer will begin re-indexing. This can take a while, depending on the number of files you have. You may experience a slowdown during this time; this is normal.

Hopefully, rebuilding the index resolves your issues with Spotlight. If not, it might be time to dig deeper or consult with Apple Support for more specialized help.

6
  • 1
    I think you should make it clear which parts have been generated by AI. The lengthy answer covers in-depth the two steps which you claim you already tried, so it's a bit confusing.
    – benwiggy
    Commented Oct 23, 2023 at 11:49
  • Thanks for the comment. I've made an edit and hope it's more clear this time. I also cleaned up some errors in the menus AI had mistyped e.g. System Preferences is now called System Settings. I wanted to add that LanchPad but since I did find the solution rather quickly is guess it wasn't necessary to lay out everything in the troubleshooting processes. Commented Oct 23, 2023 at 17:37
  • 1
    Just wanted to say that Option 1 solved this issue for me and worked with macOS Monterey 12.7.1. Thank you!
    – kingliam
    Commented Jan 18 at 20:10
  • Thanks for letting us know. I’m happy this info came of use for someone else too. Commented Jan 20 at 13:05
  • Executing the commands under "Option 1" worked! thanks a lot - its been driving me crazy. Not sure I understand why this worked and rebuilding the index via Onyx didn't but there you go. Many thanks!
    – seidnerj
    Commented Jan 31 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .