3

I have an iMac11,1 without an OS on it (Recovery mode is still on it) and I therefore want to reinstall OS X. First thing I've tried was doing it using the recovery mode. I've reformatted the "iMac HD" Volume as HFS+ (journaled), and then used the reinstall OS X option. That tries to install OS X El Capitan 10.11, but fails as it can't download it from the App Store (it says something like "try again later").

Using another iMac9,1, I've downloaded the OS X El Capitan dmg file from the Apple website, installed the Application and used the createinstallmedia command to make a bootable USB stick. Back on the iMac11,1, I booted onto that stick, but as soon as the progress bar reached the end, the prohibited sign (circle with a bar through it) came up. After researching a bit, I also tried disabling "ignore ownership" on that USB stick, however that didn't help.

I also tried booting into the online recovery, but I wasn't able to (I suspect that the online recovery wasn't shipped with OS X El Capitan yet). Lastly, I also tried to create a macOS High Sierra installation USB stick, as that is the latest version the iMac11,1 can run (and which I thought online recovery might install). For that, I used the High Sierra Patcher on the iMac9,1 to download the installer, as the iMac9,1 is unsupported for macOS High Sierra. I created the bootable USB with the createinstallmedia command though, and not with the patcher, as the iMac11,1 is supported. I still got the prohibited sign. Then I also tried the same but used the Patcher to create the USB installer, but that made no difference. Now I am out of ideas. Does someone know what my problem could be?

5
  • Is the original internal hard drive still good? I would try installing macOS onto an external drive (though that's likely to be slow with only USB2, unless you can get a FireWire drive).
    – benwiggy
    Oct 20, 2023 at 13:42
  • @benwiggy does that mean I could get to the installer when I insert another HFS+ drive? Because right now I cannot even get to the installer as the prohibited sign shows up. I can't try right now as I don't have a spare USB HDD, but I will update as soon as I can Oct 20, 2023 at 13:54
  • Can you use the iMac 11.1 in Target Disk mode hooked to the iMac 9.1 and install macOS from there?
    – lhf
    Oct 20, 2023 at 14:01
  • @lhf I guess I need a firewire cable for that? I will try that if everything else fails Oct 20, 2023 at 14:27
  • How do you know the Mac is an iMac11,1? Does the USB El Capitan installer boot on the iMac9,1? Oct 20, 2023 at 15:33

1 Answer 1

0
  1. Plug in your USB drive, into the iMac11,1.

  2. Launch Disk Utility choose your USB drive. Format it as "Mac OS Extended (Journaled)."

  3. Give a name to the USB drive, such as "Installer."

  4. Get the High Sierra Installer:

    • Download the macOS High Sierra installer from the App Store, on your iMac9,1.
  5. Create an USB:

    • Utilize the createinstallmedia command to generate an USB:

      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Installer
      
2
  • Creating the USB installer wasn't the problem, I already created that a couple of times. I actually didn't format it before but I think the command does that automatically anyways. I will try it anyways tho. Oct 20, 2023 at 14:35
  • I think I can't execute the command on the iMac 9.2 if the stick is plugged into the 11.1 (-; Oct 20, 2023 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .