1

I'm learning how to make a dotfiles backup/restore system for my Macbook Pro M1 (on Monterey 12.7). I was trying to run some:

defaults write

commands to see how it will affect the OS. Some of the commands make no change when applied. For example this one:

defaults write NSGlobalDomain com.apple.trackpad.forceClick -bool false

When open .GlobalPreferences.plist in ~/Library/Preferences/ with Xcode, I can see that com.apple.trackpad.forceClick key value was successfully registered as false. However the "Force Click and haptic feedback" check box in System Preferences/Trackpad/ was still checked ?

Can someone help me to understand this behavior. Thank you !

I've done the following steps:

  1. Set full disk access for Iterm2
  2. Make sure System Preference is closed
  3. Run defaults write NSGlobalDomain com.apple.trackpad.forceClick -bool false
  4. Using Xcode to view .GlobalPreferences.plist and make sure is was changed
  5. Restart computer
5
  • Rough guess: maybe haptic feedback is on?
    – Thinkr
    Oct 17, 2023 at 5:29
  • What do you mean ? Can you please elaborate further ?
    – m1do
    Oct 17, 2023 at 10:49
  • 1
    Are you sure that's the correct key and plist? If you change the setting in the UI, which plist has had its modification date changed?
    – benwiggy
    Oct 17, 2023 at 11:05
  • @benwiggy Thank you, this is a great tip to find the next .plist and key that I need to change.
    – m1do
    Oct 17, 2023 at 15:24
  • @m1do Maybe you have disabled Force Touch by running the command you give in the question but perhaps Haptic Feedback is still on and it makes the System Setting option still show as ticked? Apparently you have found an answer and that wasn't the problem. :)
    – Thinkr
    Oct 17, 2023 at 15:32

1 Answer 1

0

So I was looking at the wrong .plist and key from the beginning. I was able to solve this following suggestion here by user padamdam

Disable - ForceTouch and Haptic Feedback

defaults write com.apple.AppleMultitouchTrackpad ForceSuppressed -bool true

Restart is required.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .