0

I recently set up a Synology NAS to replace my previous Drobos. Never ever had any issues with the Drobos, just that they were an item that would put me in hot water if I needed to fix them ever, so off to Synology.

Setting up the Synology as per their specs for Time Machine, all worked well… I allocated 4 TB of space as I’ve done for years on the Drobo since the inception of Time Machine. However, when setting up Time Machine on a Synology NAS, it creates a .sparseimage file, unlike if backing it to an external hard disk, which would create a .backup.db file. For some odd reason by having the Recycle Bin active in the NAS shared folder (Time Machine), the .sparseimage file never really worked as intended like on an external hard disk, when it got full, it complained (Time Machine), whereas normally on and external hard disk, it would delete the oldest files to make room for the newest stuff (shrink/grow).

My research showed that if I disable the Recycle Bin on the Time Machine NAS shared folder, it will reclaim the space. It did (I was also told that first emptying the Recycle Bin was required for it to work). The only issue with that is that I lost access to months and months of backups (Time Machine), even though if I were to probe the .sparseimage file, I could see items that went back to August when I initially set up the new Synology NAS Time Machine shared folder. However, the backups for Time Machine work and the file size does not fill up the available space as it did previously with the Recycle Bin disabled. (see the reference at the bottom of Synology: Configuring Time Machine and Quotas)

However, the item I’d like to do is get away from the NAS for Time Machine and use an external 4 TB SSD. There seems to be no clear documentation in the wild about how to do what I’m looking to do.

I’d like to take the .sparseimage file from the NAS and convert it to the .backupdb required format that is necessary for external drive Time Machine devices.

Anyone?

3
  • What format is the image? To all intents & purposes APFS Time Machine drives are not copyable. See apple.stackexchange.com/questions/463617/…
    – Tetsujin
    Oct 14, 2023 at 14:42
  • Can you assist me in finding the format of the image? No tool or OS info discloses the format to me. Oct 14, 2023 at 14:58
  • What macOS are you on? Up to Catalina, TM is on HFS+, since Big Sur it's APFS. You should be able to see the format once it's mounted - i.stack.imgur.com/1kZ0M.png
    – Tetsujin
    Oct 16, 2023 at 8:03

0

You must log in to answer this question.

Browse other questions tagged .