0

I have resurrected a C++ project I was working on a few years ago in Qt (MacOS), and can no longer get debugging to work. The problem seems to be that it is trying to use the wrong (old?) version of LLDB. The current macOS version is 12.6.8. I'm not sure what the version was when I set it all up.

In Preferences > Kits > Debuggers, it lists as 'Auto-detected' both Applications/Xcode.app/Contents/Developer/usr/bin/lldb, and /usr/bin/lldb. The latter is flagged (popup appears when hovering) as 'Cannot determine debugger type' (and with a red warning marker). The other entry seems fine.

When I look in Projects > Build and Run and hover over Build (for this project) the popup window tells me 'Not recognised engine using /usr/bin/lldb', and when I try to run the code in debug mode I get the message (in Application output) 'Unable to create a debugging engine'.

It seems that Qt is finding two versions of the debugging engine, one of which is presumably OK and the other not, and then tries to use the wrong one. There is no option in the list of debuggers in Preference > Kits to remove the problematic one or to set a default.

Can anyone suggest a solution - and preferably one that isn't too complicated!

1 Answer 1

0

Problem solved -- sort of! Apparently you can install Xcode 14.3 on Monterey (from its XIF file), which I have done, but you can't run it as an application because it's 'incompatible' with it. However you can run it if you start it from the command line. Clunky, but it seems to work.

I haven't tried to install CLT because I only need it for the debugger and there's no point in complicating things unnecessarily!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .