1

Images don't load on a lot of websites. They load just fine in Firefox and Brave. Tried a lot of troubleshooting tips from other websites but nothing has worked. Running macOS Catalina, version 10.15.7 on a 2012 Mac mini (Macmini6,2) with 16 GB of RAM.

Tried tips from appletoolbox.com, tenorshare.com, techwalla.com. All to no avail.

Any ideas?

6
  • 1
    Have you opened the developer tools and checked for errors?
    – Barmar
    Oct 6, 2023 at 21:58
  • Ain’t got idea on how to do that. Oct 6, 2023 at 22:12
  • 1
    In Settings->Advanced enable "Show features for web developers". Then you can use Develop->Show JavaScript Console.
    – Barmar
    Oct 6, 2023 at 22:20
  • Where are theses settings? Oct 6, 2023 at 23:48
  • Oh you mean 'Preferences'? Oct 6, 2023 at 23:49

1 Answer 1

1

You are not using the current version of Safari. Therefore, some websites may not work correctly. If this is the problem, then the fix would be to get an updated version of Safari. This would require a newer version of macOS. Since Catalina is the newest version of macOS that is compatible with your Mac, you have the following options.

  • Get a newer Mac.
  • Install a newer version of macOS in a virtual machine. I can run Monterey (macOS 12.5) in a VMware Fusion Player (version 12.1.2) virtual machine (2 processor cores, 4096 MB of memory) on a 2013 iMac host, which is running Catalina.
  • Use OpenCore Legacy Patcher to install a version of macOS newer than Catalina.
1
  • Thanks, these are all good options. I’ll deffo try the virtual machine. Oct 7, 2023 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .