1

My M1 Macbook Pro shows all PDF files as corrupted, whether I'm looking at it in the finder preview pane, using spacebar to quick-preview or double click to open. Opening that same PDF on the same computer with Google chrome displays the PDF properly. Opening it again in Mac preview, it looks also perfect. This occurs on almost every single PDF that I want to open.

This occurs on my private M1 Macbook pro but does not occur when looking at the same files on my work-supplied M1 Macbook Pro (same setup) or my M2 Macbook Air. I first started having this issue with Monterey and hoped the upgrade to Ventura would fix it. It didn't. I too hoped (yesterday) that upgrading to Sonoma would fix it. It didn't.

So, as a last resort, I reinstalled Sonoma with the recovery assistant.

I still have the same issue.

I've also tried cleaning my cache, screaming to the wall and thinking really hard about hitting my computer, but violence never helps solve any problems.

Any ideas?

3
  • 2
    You say that "Opening it in Preview looks perfect", but you also say "double-click to open" is corrupted. What's your default PDF app? Clearly, there's some difference between your other Macs and this one. I would first try booting to Safe Disk mode, or creating a brand new user account, and testing if the problem shows there. If Safe Boot mode works: you've installed some software that's interfering. If the new user account works, then something in your old user account (could be an app set to launch; could be corrupt caches or prefs) is the problem.
    – benwiggy
    Oct 3, 2023 at 12:32
  • Also: which cache did you clean, and how?
    – benwiggy
    Oct 3, 2023 at 12:33
  • @benwiggy Default app is mac standard "preview" used in all three locations (finder pane, spacebar open and double click). Brand new account exhibits the same issue. Cache cleared from ~/Library/Caches (I deleted everything, I don't know of any other cache), and booting in safe mode exhibits the same issue. The "reinstall" didn't seem to really reinstall Sonoma, either, as my apps still worked as if nothing had changed.
    – Greg
    Oct 3, 2023 at 16:12

1 Answer 1

1

A full "erase my settings" after the Recovery Assistant (to reinstall Sonoma) worked. Now my system is back to the way it was / works the same as my other machines. I guess there's no understanding of why/how with this answer, just a "how to fix it". But, it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .