0

I'm trying to get rid of a stray Netskope Client (NSClient1) VPN entry that wouldn't go away. I found its traces only in /Library/Preferences/com.apple.networkextension.plist - this is the system's plist not my users. I'm the only user on the system and have admin privileges.

However the file is locked and despite being an admin, I can't edit it. Can someone please help me figure out how do I edit this file (or remove the stray VPN entry)?

Steps taken so far: (all result in operation not permitted or I don't have permissions to change)

  • tried to change permissions (via finder's get info option as well as chmod through the terminal)
  • tried to copy the file to the desktop, edit it and then replace
  • contacted Apple support (and they said it's not their problem - quite literally)
  • contacted Netskope (VPN support) and tried to run their uninstaller but that didn't work either

[the VPN entry doesn't get listed when I run sudo networksetup -listallnetworkservices]

I'm using macOS Sonoma 14.0

enter image description here

enter image description here

enter image description here

3
  • Is the nouchg or noschg flag set? If so, remove it by following the instructions in the chflags(1) man page.
    – Linc D.
    Oct 3, 2023 at 1:47
  • Thanks. Tried it, the chflags execute in terminal but the file remains locked.
    – zaam
    Oct 3, 2023 at 2:31
  • remains uneditable*
    – zaam
    Oct 3, 2023 at 12:40

1 Answer 1

0

It seems like the SIP (system integrity protection) on macOS was blocking changes to system plists. I had to disable that to make any edits.

To disable, boot in recovery mode and enter csrutil disable through the terminal; then reboot.

Once done, you can run csrutil enable to enable it again and csrutil status to check its status.

PS: Not recommended to do this if you don't know what this all means. Always backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .