2

I keep getting this:

-macosx_version_min has been renamed to -macos_version_min

anytime I compile anything. Any reason why? Can I prevent it?

9
  • 2
    What are you compiling?
    – IconDaemon
    Commented Oct 3, 2023 at 0:20
  • hello world @IconDaemon. gcc hello.c (not clang, real gcc) -- but it also showed when I compiled emacs with clang. Commented Oct 3, 2023 at 2:51
  • Did you update Xcode to the latest version?
    – nohillside
    Commented Oct 3, 2023 at 4:27
  • Which version of gcc?
    – mmmmmm
    Commented Oct 3, 2023 at 8:32
  • 13.1.0 @mmmmmm . Commented Oct 3, 2023 at 18:28

1 Answer 1

1

This is a change in Xcode 15.

My answer is from a quick google and seeing other bug reports on this issue however I haven't looked in enough detail to say more than the line above but I think the issue is Apple introduced a new linker (and also renamed the old one to classic which was already used)which has this change in flag.

gcc have also changed their code to fix this From the gcc bug

Darwin: Use -platform_version when available [PR110624].

Later versions of the static linker support a more flexible flag to describe the OS, OS version and SDK used to build the code. This replaces the functionality of '-mmacosx_version_min' (which is now deprecated, leading to the diagnostic described in the PR).

We now use the platform_version flag when available which avoids the diagnostic.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .