My system drive is tiny and my second is 2TB. Therefore I would like to store the Sonoma Aerial videos on the second drive. If I use shuffle, there's approximately 57gb of them.

I presumed that macos would treat a symlinked directory like a regular directory but I'm having trouble with the following:

  • I move the 4KSDR240FPS directory (with all videos downloaded) to the second drive.
  • I create a symlink of the 4KSDR240FPS directory via: ln -s ... (and confirm it works etc).

The problem is that the screensaver system preferences act as if there's no videos in the directory. If I empty the directory and attempt to re-download any of the videos via system preferences, it completes the download symbol but nothing happens. There's no video in the directory and a revisit to system preferences suggests it needs to be downloaded again.

  • I've tried giving both root and user (who is an admin) permissions to the symlink but it hasn't changed anything.
  • I've also tried deleting the rest of the files in the com.apple.idleassetsd directory (that parents the 4KSDR240FPS directory) and let macos rebuild them when I open the system preferences (which it does). But the problem persists.

Any ideas on hosting the videos outside of the system disk (other than using third party screen savers that I'm aware of)?

note: I'm using the name 'Aerial' as I've seen the Sonoma system video screensavers referenced as this. I'm aware that there's also a third-party app, of this name, using similar videos for a similar screen saver and I'm not referring to that.

Update 1

I deleted the 4KSDR240FPS symlink and let Aerial recreate the directory by choosing a video from the prefs. It does appear to download it outside of this directory and only moves it into it when the download is complete. If using a symlink, this final move does not happen for me.

Update 2

I attemped to use the synthetic.conf solution linked to in the answer @chronospoon gave. The following command in terminal:

echo -e "Library/Application Support/com.apple.idleassetsd/Customer/4KSDR240FPS\tVolumes/Twotb/Library Annexe/Application Support/com.apple.idleassetsd/Customer/4KSDR240FPS" | sudo tee /etc/synthetic.conf

Did create a synthetic.conf file withe above command. I checked it had a tab character and did not have leading slashes. I also made sure the target 4KSDR240FPS existed (by creating a new, empty dir).

Restarting the mac produced no Library/Application Support/com.apple.idleassetsd/Customer/4KSDR240FPS symlink of any kind

  • Permissions on the symlink don't matter, permissions on the target of the symlink matter. Are the permissions on the external folder set correctly? Commented Oct 2, 2023 at 22:39
  • The target directory was copied over and permissions are as per the sibling folders (e.g. 2KSDR, etc.). That is, everyone has read permissions and the default admin user has read write permissions Commented Oct 3, 2023 at 10:25

1 Answer 1


Two things come to mind:

  • One is that screensavers are not full-fledged applications, and subject to more stringent access controls. They may only be able to access files/symlinks from within ~/Library/Data or Library/Containers, though my experience with this is with a screensaver I wrote and compiled myself.
  • The other is that I believe downloaded assets (definitely wallpapers and dictionaries, probably screensavers as well) get subject to some kind of SSV-ish cryptographic verification. I never quite understood how to preserve permissions/signatures when moving downloaded dictionaries around.

I'd suggest checking if a symlink on the same volume works, first (the same APFS volume, if it's not one of the sealed ones).

You might also be able to use synthetic firmlinks (mentioned e.g. in this SO answer), but they seem to limit you to the Data partition/same APFS container.

  • Thanks for the insightful thoughts. Having created a symlink on the same volume, the problem persists. I also followed the advice of using /etc/synthetic.conf that you linked to. Is it confirmed functional in Solina? I believe I've followed every step correctly and no firmlink is created. I've checked my /etc/synthetic.conf after restarting and it appears correct, with a tab character etc. Commented Oct 5, 2023 at 9:30
  • *Sonoma (I've gone beyond the edit time threshold) Commented Oct 5, 2023 at 9:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .