1

I tried to factory reset a Late 2014 Mac mini by holding Command + R while booting, which took me to Internet Recovery for macOS Sierra, I used the Disk Utility to erase and format the drive, then I closed Disk Utility and clicked reinstall OS. It went on for a while but then an error appeared towards the end of the installation.

An error occurred while preparing the installation. Try running this application again.

I've tried reformating multiple times and following online guides to reset PRAM and SMC but no matter what I keep getting this error when installing the OS.

I opened the install log and saw some errors in there:

WARNING: SecPolicyOID failed to return an OID. This function was deprecated in 10.7. Please use SecPolicyCopyProperties instead. Failed to get secure URL from recovery catalog LB recovery fetch failed with error: Error domain=com.apple.installer.fixme.error code=2000

and a whole bunch of could not find package ref in any source for com.apple.pkg.xxx

4
  • 2
    Do you know the year of the Mac mini? Do you know which version of OS X/macOS Recovery you are booting to? Do you know if you are booting from the Recovery on the internal drive or Internet Recovery? I ask because most likely if you have booted to the Recovery on the internal drive, then you could not erase the internal drive. However in your question, this is kind of what you are saying you have done. Sep 30, 2023 at 15:23
  • @DavidAnderson It says A1347 EMC2840 on it, which google says Mid-2010. The installation says macOS Sierra. I believe both, sometimes I boot it up and there's a spinning globe, it asks for a wifi connection and then does some stuff for a while, I guess this is the internet recovery. sometimes I boot up with command r and in the disk utility there's iirc a recovery image or something like that in a section underneath the drives. I've done the process multiple times in slightly different orders and stuff, so if you need me to do one end to end again or anything else let me know thanks.
    – Aequitas
    Oct 1, 2023 at 3:52
  • A1347 could be anything from 2010 to 2014, but EMC2840 narrows it to 2014.
    – Tetsujin
    Oct 1, 2023 at 7:39
  • There is the question "How do I create El Capitan installer on a Catalina (or post-El Capitan) installed Mac for use on USB boot installer?". The answer with the most votes states given solution for El Capitan can also be applied to Sierra. Oct 10, 2023 at 2:25

1 Answer 1

1
+50

One possible route would be the following.

  1. Instead of Cmd ⌘ R, use Shift ⇧ Opt ⌥ Cmd ⌘ R at startup. Erase the entire internal drive as APFS, then install (what I assume with be) Monterey.
  2. Download the InstallOS.dmg file for Sierra. See Use a web browser.
  3. Use the InstallOS.dmg file to create the Install macOS Sierra application.
  4. Create a USB Sierra bootable installer. See Create a bootable installer for macOS. The command for Sierra is given below.
    sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ Sierra.app
    
  5. Boot from the USB Sierra installer. Erase the entire internal drive as Mac OS Extended (Journaled), then install Sierra.
7
  • I've been trying to create a usb bootable installer but the problem I'm having is your step 3. I can't open the installOS.dmg file. mac says "This version of macOS 10.12.6 cannot be installed on this computer." and it doesn't seem to be possible to create it from the dmg file. I found online that you could use transmac to do it, but it doesn't seem to work for me, after trying, and everything seemingly worked I plug it in but the mac mini doesn't seem to want to notice the usb as being bootable.
    – Aequitas
    Oct 9, 2023 at 1:13
  • I realize you are trying to install Sierra. However, the answers given to the first duplicate question cover Sierra, as well as El Capitan. There are many posts on the web regarding TransMac. Often these posts do not work or do not apply to Sierra. The method given as the accepted answer in the second duplicate question has been tested to work with Sierra. Oct 9, 2023 at 8:52
  • Thanks for those, it seems similar to what I've tried previously. Thankfully though I managed to find a youtube video with a downloadable 'patcher' file, that allowed downloading and creating usb installers on incompatible macs, which worked flawlessly for me.
    – Aequitas
    Oct 10, 2023 at 1:27
  • Stating you found a video + file does not explain your solution. For this question to be useful to others, you would need to post an answer with sufficient details that would allow other users implement your solution. At present, I still see your question as a duplicate at least two previous questions. Can you at least post a comment with a link to the video. Also, if you used a different Mac to create the USB installer, then could you post the model/year of the Mac? Oct 10, 2023 at 2:28

Not the answer you're looking for? Browse other questions tagged .