0

My App Store on iPhone (iPhone 4S with iOS 5.1) is stuck, I already contacted the support from apple. But maybe there is someone here with a similar experience.

Whenever I open the App Store, it looks like the apps keep loading.
Here is a screenshot:

screenshot

After 30 minutes, it still looks the same.
It can't be a connection error since Safari is running smoothly.

I've tried to reset my iPhone to factory settings three times, but it still looks the same.

  • 1
    I've had this happen recently and it seems to have cleared on its own. I just left the iPhone alone for a while and it cleared up. This isn't offered as a solution for you but it might be that the app store burps from time to time and needs a bit of time to get it's digestive system back in order. – Richard Mar 28 '12 at 22:27
1

I would try disabling your cell phone connection (Settings > enable Airplane Mode), then enabling Wi-Fi, and connecting to another Wi-Fi hotspot (you could even try a public one such as a local coffee shop or an Apple store). Perhaps there is some kind of filtering going on with your Internet connection.

If you have a 3G plan, you could (and probably should) do the opposite too:

  1. Set Airplane Mode to off (so that it uses your 3G connection)
  2. Turn Wi-Fi off
  3. Try accessing the App Store.
  • apologies, i forgot to mention if i still able to connect app store via iTunes from my mac. So i think this not from my ISP. And also already tried with 3G connection, still no result. – GusDeCooL Mar 28 '12 at 18:17
  • 1
    @GusDeCooL: While it's probably similar, iTunes on the Mac is not necessarily the same thing as the App Store on the iPhone. I would try the Wi-Fi test above for good measure... especially if you can do it in an Apple Store and show them the problem! – Senseful Mar 28 '12 at 18:30
  • @GusDeCooL, since your iPhone's safari works fine, have you tried to restart your iPhone? If there's some system process that's "stuck", doing so might fix the issue. – JW8 Mar 28 '12 at 18:56
  • @JW8: He mentioned in the original post how he tried reseting to factory settings. I think it restarts it at least once each time you do so. – Senseful Mar 28 '12 at 22:18
  • @Senseful, got it - hadn't needed to reset to factor settings and wasn't sure if a reboot was part of it. – JW8 Mar 28 '12 at 23:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .