1

After updating my MacBook Pro to Mac OS Sonoma, I've tried to install Apple's Game Porting Toolkit (GPTK).

I've followed the AppleGamingWiki guide.


Unfortunately, after installing + starting Steam using these 2 commands, I get the error as shown below:

# Install
gameportingtoolkit ~/my-game-prefix ~/Downloads/SteamSetup.exe

# Run
gameportingtoolkit ~/my-game-prefix 'C:\Program Files (x86)\Steam\steam.exe'

Error: enter image description here


I came across a github issue that suggested to manually start steamwebhelper.exe and steamservice.exe before starting steam.exe. I've tried that, but the same error occurs.

Somebody else suggested to copy the config, registry.vdf and userdata files from the MacOs Steam to the Windows variant, again, the same error occurs.

Another suggestion that didn't work was to launch Steam using these arguments:
-allosarches -cef-force-32bit.


Does somebody know how to resolve this issue?

1
  • If somebody with 150+ rep could tag this on gptk, that would be nice ;)
    – 0stone0
    Commented Sep 27, 2023 at 15:57

3 Answers 3

1

After playing with for a while, I've found a set of commands that seem to work.


  1. Kill all running wine64-preloader commands:

    killall wine64-preloader
    
  2. Place the 'Replacement command' in your ~/.zshrc:

    Note: Don't forget to replace ~/my-game-prefix with your chosen prefix

    wine-gptk(){ WINEESYNC=1 WINEPREFIX=~/my-game-prefix $(brew --prefix game-porting-toolkit)/bin/wine64 "$@"; }
    

    I'm not sure why, but this command seem to work a lot better then directly running
    game-porting-toolkit

  3. Restart your terminal to enable the wine-gptk command

    source ~/.zshrc
    
  4. Enable x86_64 shell:

    arch -x86_64 zsh
    
  5. Start Steam

    wine-gptk 'C:\Program Files (x86)\Steam\steam.exe'
    
  6. (Optionally) Since some game's wont launch from Steam, start the .exe manually in a new terminal window after starting Steam, eg:

    wine-gptk 'C:\Program Files (x86)\Steam\steamapps\common\Zeepkist\Zeepkist.exe'
    
0

Hope this work for u, worked with me https://www.youtube.com/watch?v=V_QfDyFaM7s

1
  • 2
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Sep 28, 2023 at 16:16
0

I solved the problem by installing an older whisky. Version 2.0.1 worked. Make sure to removing the current version completely from your Mac. ( https://www.youtube.com/watch?v=IgRi0Z1O_gk&t=104s ). The time to launch the installed steam takes still around 40s but it will not crash.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .