10

I've followed the instructions to Create a computer-to-computer network on Mac, set up a temporary, ad hoc Wi-Fi connection between your Mac and another device.

Unfortunately, enabling legacy networks doesn't cause a create menu item to appear.

Use case: I want to use Syncthing to sync files even when I have no internet (e.g. I'm on a flight).

There should be a "Create Network" menu item according to the Apple Support page.

Screenshot of the Wi-Fi status icon in the menu bar

1
  • Same problem here, did you ever figure it out?
    – Martin
    Oct 16, 2023 at 3:33

3 Answers 3

0

They have hidden this option under System Settings -> General -> Sharing -> Internet Sharing.

You then need to select from which interface to which interface you want to setup the sharing. You'll most likely want to select a wired interface as the source, and WiFi as the destination.

internet sharing options

(I swear I could select WiFi as the destination a minute ago... (╯°□°)╯︵ ┻━┻)

When you select WiFi as the destination, the "Wi-Fi Options" button can be clicked, and there you'll see the usual WiFi hotspot options.

1
  • 1
    Unfortunately, this does not answer my question. You're sharing an internet connection from your iPhone here. I'm asking for a computer to computer network, even when I don't have internet. I tried this in the past, and it didn't work. The setting you're referring to has been there for a while. Oct 23, 2023 at 8:31
-1

As a temporary solution to connect the 2 devices, I've connected my android and macbook device using an ethernet cable and 2 usb-c <-> ethernet adapters. After configuring static IPs, it works.

However, it's quite clunky! I'd prefer a computer-to-computer wireless network supporting multiple devices. I don't want to bring a network switch...

Same diagram as https://superuser.com/a/1655603.

1
  • 1
    Sounds like you still need some help. You may get it faster or better if you provide your progress as an update to your question rather than an answer.
    – Alper
    Sep 23, 2023 at 7:55
-4

I found it! and it works like a charm ;)

https://www.makeuseof.com/how-to-create-a-secure-ad-hoc-network-in-macos/

Thanks to Matt Moore!

https://www.makeuseof.com/author/matt-moore/

8
  • 1
    Please don't post link-only answers. They not only make for a bad user experience because people have to jump off-site for the actual answer, they also don't show up in search. Also, the answer becomes useless when the link breaks. So, please summarize the solution directly in the post and leave the link for reference, please.
    – nohillside
    Nov 14, 2023 at 7:52
  • Also, the linked article seems to recommend the solution the OP already tried, and which didn't work for him.
    – nohillside
    Nov 14, 2023 at 7:54
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Nov 14, 2023 at 8:02
  • That article you linked to seems like a bad idea. sudo networksetup -createnetworkservice AdHoc lo0 and sudo networksetup -setmanual AdHoc 192.168.1.88 255.255.255.255 means using the loopback port and changing the IP from 127.0.0.1 to something arbitrary. Any applications connecting to 127.0.0.1 will not hit the loopback anymore. Breaking local applications communicating. Nov 14, 2023 at 22:05
  • 1
    @BenButterworth I just tried this, but replacing 192.168.1.88 with 127.0.0.1. That seems to work fine, and ssh'ing into 127.0.0.1 works (as opposed to with the proposed solution). Do you still see any problem with this?
    – Martin
    Nov 15, 2023 at 14:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .