I have an ExFAT drive which carries my works, including codes that I'll be using between Mac and Windows. I've always used TUI GNU Emacs on this drive to ensure no resource fork is accidentally created.

Recently, I re-installed the entire operating system to eliminate a problem with Native Instruments softwares that I didn't manage to find the cause. Since then, whenever I create or modify a file on the ExFAT drive from iTerm2 command line, resource fork for that file gets created. I tried the Apple Terminal, it won't create resource fork even for the exact same commands I've typed on iTerm2.

How should I prevent resource fork from being created by iTerm2 in this case?


Thanks for the answer from @Tetsujin (刺青人?), But I insist on finding the problem with iTerm2. This ExFAT drive is primarily for coding and exchanging data with other computers (Win, Linux, BSDs, whatever other lesser known OSs.)

Lacking ACL and permissions is considered a plus for my purposes. Also, my creativity works are on another APFS drive to get backed up in Time Machine, so no worry they get harassed by a foreign OS.

  • 2
    This will be nothing to do with iTerm2. iTerm just runs shells and it is these shells and the commands you run that do any chnages to files. Are you using the same shell in Terminal and iTerm?
    – mmmmmm
    Sep 22 at 17:16
  • @mmmmmm I tried running the touch command under ksh in both terminals, and observed iTerm2 creating resource fork and Apple Terminal doesn't.
    – DannyNiu
    Sep 23 at 1:34
  • macOS assigns full-filesystem permission to Apps rather than individual program files, so I suspect it's some setting affecting the iTerm2 app.
    – DannyNiu
    Sep 23 at 1:37
  • The only xattr present on these rsrcs seem to be com.apple.provenance, which is related to SIP protection. Could also be the cause for NI softwares. Related Q: apple.stackexchange.com/q/450118/193252
    – DannyNiu
    Sep 23 at 8:21

2 Answers 2


Use something other than ExFAT.
It's not just resource forks, it's all unix perms & ACLs. FAT just cannot handle them, so the Mac tries to wrap them in a dot underscore file, but it's not always successful. Especially as you're using Native Instruments … don't ever put anything like Logic projects [or any bundle like a Photos Library etc] on any FAT structure, or you risk them being broken.

You're best to use HFS+ & get a reader for Windows, like Paragon HFS for Windows

  • Thanks, I may consider it as last resort. But for now, I still look for a fix on iTerm2.
    – DannyNiu
    Sep 22 at 13:55
  • OK, no worries:) btw, I don't actually speak much Japanese, but it was my nickname when I worked for a Japanese multinational some years back - it's from 鉄人28号 the cartoon character ;))
    – Tetsujin
    Sep 22 at 15:38

Add iTerm2 to the "Allowed list" and toggle on the switch in:

System Settings > Privacy & Security > Developer Tools.

As mentioned in the comment, there's the com.apple.provenance xattr affecting the security label of certain apps. Developer settings seem to disarm it.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .