1

Using my Macbook, I connect to the secure Wi-Fi at the hospital where I work, and the internet usually works beautifully. After several days of sleep-wake cycles, the internet gets slower. Eventually, I am unable to even connect to Wi-Fi. I restart my computer, and it works again--for a few days. And the cycle continues.

It is quite inconvenient to restart my computer every few days. Turning Wi-Fi on and off does not work. Deleting the Wi-Fi network and reconnecting does not work. All that works is a system restart. The Wifi is secured with WPA2 Enterprise. The Diagnostics built into the OS reveal nothing at all. My home Wi-Fi, and any other Wi-Fi network does not have this issue, even without restarting for months.

I am using a 2023 Macbook Pro with a Apple M2 Pro chip, running Ventura 13.4. Interestingly, I had the exact same issue with my old Macbook Pro, which I was using up until 6 months ago. I tried calling the IT service desk, and they had no idea how to help. I do not know of any of my colleagues with this issue.

Do you know what is going on and how to fix it?

If not, is there any way to restart only the networking? As I mentioned, turning wifi on and off does not solve the problem; there must be a way to do a "deeper" restart of the networking that would simulate what happens when I restart the computer.

Edit - Additional diagnostic information in response to comments.

  • No other processes on the Activity Monitor with heavy network usage
  • Pinging a local IP address with response times of 12,000 - 13,000 ms, so extremely latent. This is a server I am ordinarily able to access with no latency at all.
  • Unable to load Fast.com.
  • Tried renewing DHCP lease to no avail
  • I do usually move around quite a bit in the hospital, but in this past cycle where it went from working to not working, I was in the same room. During this shift, the Internet went from working perfectly early in the shift, to then after I woke it up later in the shift to being completely unusable.
  • RSSI - 66dBm, Noise: -90 dBm. Seems to be stable over the course of a few minutes. Full signal on the Wifi.

Edit 2 - I disconnected and reconnected the wifi which sometimes fixes it, sometimes does not. This time, it did fix it. The ping to that local server is down to ~30ms, internet works just fine, and RSSI -61 dBm, Noise -94 dBm.

10
  • You say that the built-in diagnostics reveal nothing. What does that mean exactly? For example, have you checked Activity Monitor to see whether something is churning the network? Also, there are two aspects to network speed: bandwidth and latency. Are they both slow, or only one? You can test with a speed tester such as fast.com and by pinging hosts both inside and outside the local network.
    – Linc D.
    Sep 19, 2023 at 22:27
  • If you hold down the option key and open the Wi-Fi menu in the menu bar, you'll see some diagnostic information about the connection. What are the values for RSSI and noise? Are they changing over time?
    – Linc D.
    Sep 19, 2023 at 22:37
  • You could also try renewing the DHCP lease: support.apple.com/guide/mac-help/…
    – Linc D.
    Sep 19, 2023 at 22:43
  • Why, exactly, is it inconvenient to restart every few days? At our school, a host of network related problems on our users' laptops disappear immediately when the laptop is restarted. Your experience may have to do with the WiFi topology at the hospital. Q: Do you move around from room to room in one building, perhaps on several floors, over the course of the day? Q2: Do you go to other buildings which provide the same WiFi access?
    – IconDaemon
    Sep 19, 2023 at 23:18
  • @LincD. thank you for the questions. I responded by editing the question. Sep 20, 2023 at 10:02

1 Answer 1

0

I've had this issue on and off for the past year and it resurfaced days after macOS update.

In my situation, the issue is caused by Avast Filters and there is no need to restart macOS.

To fix:

  1. Go to System Settings >> Network. You should see Filters are active.
  2. Click Filters. From the option, select disabled. Your wifi should automatically connect.
  3. Select Enabled again and you're all set.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .