0

I purchased a 2020 M1 13" MacBook Pro in March 2021 and it's been like driving a racing car. I use it for everything, and I do a lot as I'm a post-graduate researcher in Electrical Engineering. This machine has been great and I've had no issues, until now...

What's Happened:


Certain apps/commands in terminal are incredibly slow to execute. Specific examples that I've observed:

  • git status [several minutes to process]
  • Apple's built-in screenshot tool (mapped to button on touch-bar) [15-30 seconds to open]
  • Apple's built-in dictation [not yet waited long enough for it to be ready]
  • Apple's archive utility [30-60 seconds to process]
  • Apple's terminal shell prompt [several minutes to be ready]
    • This has also been observed via the terminal in VSCode
  • Running a Ruby Jekyll local server via VSCode (or via terminal) [11 minutes to process]

The previously longest process from the above list would be the Ruby Jekyll server, which previously took <2 seconds to process. Now it's 11 minutes...

When/How Did it Start:


I was using the machine fairly heavily for work and leisure as usual. I was about to go on holiday for 2 weeks so I shut it down and left it in a drawer, as I wasn't taking it with me. I returned, booted it, and immediately all of these issues have presented.

Potential Causes I Have Disproven:


  • Hardware issues - Apple diagnostics return no issues
  • Low disk space - 237 GB remaining on a 500 GB SSD
  • Updates - I have not run any specific system wide updates before or after the start of this issue
  • Malware - virus scans with Avast and Malwarebytes return no finds
    • All potentially suspicious software recently installed has been completely removed during my diagnostics

Attempted Remedies that Haven't Worked:


  • Updating git
  • Clearing more disk space
  • Deleting all data in /Users/<username>/.zsh_sessions
  • Deleting all data in /private/var/log/asl
  • Deleting /Users/<username>/Library/Preferences/com.apple.Terminal.plist
  • Inspecting .zshrc - no changes there for a long time
  • Rebooting (I generally reboot once every 3 months (usually by which time the machine has crashed) however I have tried several reboots with no improvements)

Related Observations:


  • This does not affect overall system performance. When processes are stuck, the rest of the machine appears to be operating entirely normally. CPU usage is around 10% - no beachball of death
  • This does not affect all apps - I can open and close Chrome with no issue, for example. Only certain apps are affected
  • I can open VSCode (for example) without a delay about two-thirds of the time. The other third, there is a delay of 15-30 seconds. There then may or may not be a 1-3 minute delay for the shell prompt to become available when I open the terminal pane
  • Once an app/process has successfully worked through a delay, it generally won't experience one for the next 12-24 hours
    • After a delay with git status, there were then no delays with git status. There was then, however, a delay with git push (not add or commit, run inbetween). There were then no delays with git push that day, thus the delays are not wholly persistent
  • Once an app/command finally runs, it will usually be as quick as before to execute (with the exception of bundle exec jekyll serve -l which can still process slowly once started)
  • I had narrowed it down to the shell, as it is commands executed here and it's use within VSCode that were the primary symptoms, hence my deleting of various logs and .plist's, however I am no longer so sure
  • Disconnecting from the internet does appear to be a workaround, that causes the processes to complete immediately
    • I have used Wireshark to inspect my network traffic during hangs. There is some TCP communication to Apple servers, but that's about it
    • This is not related to internet connectivity, speeds, or firewalls. I have the same issues at home and at my university campus (with ~850 MB/s download speeds)
      • Other Mac users on both of those networks do not report issues
      • I do run LuLu, but haven't modified any settings in recent months. Disabling LuLu hasn't helped
    • I assume this is not an issue on Apple's side as other Mac users are not suffering with this

System Details:

(as far as I can see would be relevant)


  • M1 MacBook Pro
  • 16 GB RAM
  • 500 GB SSD
  • Big Sur 11.1
  • Git 2.42.0
  • Ruby 3.2.2
  • Jekyll 4.3.2
  • Chrome 117.0.5938.62
  • VSCode 1.82.1

As you can imagine, waiting minutes (or even 11) for what were previously small, slick operations to take place is infuriating. I believe there is some sort of delay with my machine verifying certain apps/processes with Apple's servers, but I am at a loss as to what could be the underlying cause, especially as everything was running fine, and then suddenly wasn't.

I have been unable to find any new advice that I haven't tried already so am now reaching out (usually my last resort).

I welcome all and any advice. Thank you in advance.

1
  • 1
    I suggest you start by removing your useless "anti-virus" software, which you should do regardless of whether or not it's causing this problem. If. after doing that, there's no improvement, start up in safe mode and test.
    – Linc D.
    Commented Sep 14, 2023 at 18:03

0

You must log in to answer this question.

Browse other questions tagged .