1

I'm a new Mac user, so please have mercy.

I have 2 keyboard layouts configured: Dvorak and US International.

My issue is the following: when the Dvorak keyboard is selected, all shortcuts seem to use the US International layout.

For example, to copy text, the shortcut is not Cmd+C, but rather Cmd+J and the J on the Dvorak layout is in the location of the C on the US International layout.

In other words, it seems like the layout for the shortcuts is using the US International layout, no matter which layout is active.

I can think of a few reasons for this, common shortcut locations (Z, X, C, V) are clustered on the US International layout, but not on the Dvorak layout. Still, I'd like to use the layout I selected for all characters I type, regardless of the modifiers that happen to also be pressed at the same time.

How do I accomplish that? I cannot find any information about this here on the forum, nor in the Mac settings.

5
  • So, if I understand you want the keys you use for the shortcut to follow the characters on each keyboard you select? That sounds good for muscle memory...
    – Solar Mike
    Sep 12, 2023 at 18:01
  • Apple provides 2 Dvoraks: Dvorak and Dvorak Qwerty Command. Have you tried both? Sep 12, 2023 at 21:03
  • US International PC is a special layout which turns '"`~ into deadkeys to make accented characters for common European languages. If you do not need that, I suggest you switch to US or ABC instead. Sep 12, 2023 at 21:04
  • @TomGewecke thanks for that, i feel like such an idiot :) I hadn't seen the "normal" dvorak layout when setting up the system. If you want to write it up as an answer, go ahead and I'll accept it
    – ElRudi
    Sep 13, 2023 at 6:55
  • Also @TomGewecke: I was aware of the dead keys in the US international layout, but I couldn't find the normal US layout. Turns out, in that case, US is written with periods: "U.S.", instead of without as in "US international". Thanks for making me double check
    – ElRudi
    Sep 13, 2023 at 6:58

1 Answer 1

1

It sounds like you are using the input source called "Dvorak Qwerty ⌘." Instead try the one called simply "Dvorak."

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .