6

After installing skype it will always start whenever I login. I'd rather it didn't do that.

How do I stop Skype from automatically starting?

7

Alternate Method (for Snow Leopard and possibly * Lion):

  1. Open System Preferences
  2. Select "Accounts"
  3. Select your user account
  4. Select "Login Items" at the top
  5. Remove "Skype"

Ta-da!

5

Since an image is worth a thousand words (make sure the options isn't checked):

enter image description here

1
  • 2
    This does not disable auto-launch in the current version of Skype (v8.51). – Abhi Beckert Sep 16 '19 at 0:37
4

For Skype for Business on Mac OS Catalina:

  1. Right click Skype icon in dock, click Options, ensure "Open at Login" is not selected
  2. Right click Skype icon in dock, select "Quit"
  3. System Preferences
  4. Users & Groups
  5. Select user in left pane
  6. Click "Login Items" button in right pane
  7. Select "Skype for Business" from list and click minus button at bottom of pane
  8. Repeat previous step if more than one "Skype for Business" is in the list
1

This worked for me.. first list all login items:

$ osascript -e 'tell application "System Events" to get the name of every login item'

Then delete skype for business

$ osascript -e 'tell application "System Events" to delete login item "Skype for Business"'

You may need to run several times if there were repeated items.

0

Right click the Skype icon in your dock and then, under "Options", untick "Open at Login".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .