0

I am trying to revive my old 2012 MacBook Air (Model A1465) to use an older version of MacOS for a program that could only run on MacOS High Sierra or earlier. Luckily the Mac comes with a reinstallation process for installing Mac OS X Lion, which is perfectly fine. See the problem that I have is that even if I tried installing High Sierra, I couldn't because I have an M1 Mac, so on the app store its inaccessible. Even if I got High Sierra downloaded the createinstallmedia command given by apple wont work because zsh: killed sudo --volume /Volumes/MyVolume because Apple is too stupid to understand that some people want to create an old boot for an old computer. When trying to reinstall Lion on my old Mac through the internet it tries to, and then ends up being a failure saying that it couldn't install it. I looked it up and some people said something about changing the date because the certificate expired on Apple's end but it still didn't work.

Therefore my last resort was to creating a bootable usb drive. I managed to download the Lion dmg file provided by Apple, and eventually found this guide to manually create a boot without using createinstallmedia: How do I create El Capitan installer on a Catalina (or post-El Capitan) installed Mac for use on USB boot installer?

I followed all the steps as was said, no errors (except for the asr error but as he said it could be ignored, unless if I should try doing the alternative). It had MacOS X Lion on the thumb drive and ready to go. I eject it, put it into my 2012 MacBook air (note that the laptop is completely wiped so no OS or anything on there, has the file with a question mark icon appear if you don't go into recovery mode), and turn it on. I then notice a problem, it turns on, but the screen just stays white for abnormally long. If you took it out it would resume as normal, but when you put it back in things froze up. I tried it again and this time it didn't do the freezing thing as much, but it would slow things way the heck down. It took 3 times as long for the file with ? mark to appear or for internet recovery to appear (note it never showed the option of which drive to boot from). After this point it kind of just ignored the drive completely

No idea what to do and Im running out of options from what I can tell. Any help would be appreciated, Thanks

7
  • The link you posted is for creating an bootable El Capitan USB installer. So why did you not download El Capitan from Apple instead of Lion? Otherwise, the instructions for creating a bootable USB Lion installer thumb drive can be found here. Commented Sep 2, 2023 at 10:09
  • I used the link but instead replaced all the instances of where it said El Capitan in the commands to Lion, and the dmg file was for Lion, so it worked just fine Commented Sep 2, 2023 at 12:43
  • I tried with your link exactly as it says, still gives me the blank screen. I retried the link with El capitan (again replacing everything with Lion but this time I noticed the Scheme he put it on for erasing was Master Boot Record instead of GUID), still gives a blank screen as well Commented Sep 2, 2023 at 13:56
  • Have you tried using the key combination Option-Command-R during startup? This is suppose to offer the latest macOS that is compatible with your Mac. This would probably be newer than High Sierra. If successful, then at least you would have a booting macOS. This would make it easier to then install an older version of OS X or macOS. This would also confirm you have a working bootable Mac. Commented Sep 2, 2023 at 19:54
  • I'd recommend David's method too. Just to note, I've had no joy building anything earlier than Big Sur on an M1 Mac, even using MDS, yet I can build [pretty much] anything on an old Intel currently running Mojave.
    – Tetsujin
    Commented Sep 3, 2023 at 9:09

1 Answer 1

1

Ok so I found the solution to the problem. The problem was with the USB stick not anything else. For some reason the MacBook upon rebooting and holding option didn't like the USB stick and so froze whenever you put it in. Therefore I switched to another USB stick and put High Sierra onto there and it worked perfectly fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .