I have a mate's 5th generation iPod 30gb from 2005. It kept popping up saying "check for errors" on my Windows 7 so I finally ran the check. I then loaded it up in iTunes, but it froze and I shut it down. Now it's not showing up in iTunes at all! It shows up in Windows but not iTunes, any ideas? I've got all the most up to date software. Did all the error checks, service checks, emptied temp folder etc and still no luck.


I found the following answer and it has worked!


In brief, the solution is to:

  • Disconnect the iPod.
  • Uninstall iTunes and iPod Updater and reboot.
  • Hold down the Center and Menu buttons until the Apple logo appears on the screen (i.e., force a reboot).
  • Connect the iPod.
  • When the iPod appears in Disk Management (My Computer > Manage > Disk Management in Windows XP), format it as FAT32. Do not use Quick Format.
  • Install iPod Updater (not iTunes) and restore the iPod.
  • Reinstall iTunes and refresh iPod contents as desired.
| improve this answer | |
  • 1
    Also, please summarize the contents of the link. Link have a tendency to disappear over time, leaving an answer that has no worth to those who may find your answer in the future. – daviesgeek Mar 29 '12 at 16:30

Have you tried to 'Restore' the iPod? iTunes will reset your iPod completely and restore you iPod software as he was new. You'll lose all your music and data, but there is a good chance you'll be able to use the iPod again.

Since you aren't able to see the iPod in iTunes, you can restore it using the iPod itself. You can reset by holding down the MENU and Center buttons together for about 10-15 seconds, when the apple logo appears hit left + center...that takes you to the diagnostics menu. Play around in there, I think there's an option to do it.

| improve this answer | |
  • Hmm. How would I do that? I think I may have to. – dpDesignz Mar 28 '12 at 7:54
  • I just looked it up and it says I need iTunes. The problem is it's not displaying in iTunes. – dpDesignz Mar 28 '12 at 7:56
  • Ok, sorry. See my update! – Michiel Mar 28 '12 at 8:00
  • Thanks. No still not working. Tried it on a couple of computers now and still only showing in explorer – dpDesignz Mar 29 '12 at 6:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .