28

I purchased a Late-2011 MacBook Pro 15" used a month ago. At the time of purchase, I successfully ran the Apple Hardware Test.

I've since installed a new SSD and aftermarket RAM. The computer appears to be functioning normally (I'm typing this post on it), but I'd like to run the full hardware test to verify everything is OK.

But I can't seem to get it to load into the hardware test. I've tried holding down D before pressing the power button on as well as right before the grey screen comes up. I'm confused because I've done this before without any problems.

Is there something obvious I'm doing wrong or is there a way I can check for problems that would stop the AHT from starting?


Additional info by @gentmatt:

The last time I have performed the Apple Hardware Test, my MacBook Pro was running 10.7.2. As of today, I'm running 10.7.3.

The AHT loaded even after I had installed my custom SSD and RAM. But not this time.

  • 2
    Honestly, AHT is useless junk. It's not worth your time stressing over it not working. – Dan Barrett Apr 29 '12 at 12:46
  • I suppose AHT has some uses, but mostly I just want the time back I spent trying to use it and then trying to see what the messages mean if it actually finds something (or dealing with the occasional false positive result.) Or what @DanBarrett said. – bmike Dec 6 '12 at 2:03
  • 4
    I'll just leave it here, cause that's what helped me in the long run. I tried it all, D, cmd-D, option-D, nothing worked, until I stumbled on this link: github.com/upekkha/AppleHardwareTest. After installing missing AHT files, just pressing D worked on my MacPro5,1. – favoretti May 27 '15 at 5:16
  • ^^^ This comment should be the accepted solution. – hyperknot Mar 20 '18 at 0:47
  • What irritates me is that it is not clear if D is shift+d or just d. If it's shift+d why doesn't anybody name it like that :( – Trace Jul 20 '18 at 15:03

13 Answers 13

33

Pressing +D right after pressing the power button and before the gray screen appears works on my late-2011 15" MBP. This forces an internet-based hardware test, which will work even if you've lost the the local hardware test software. (It will probably work over WiFi, but you have more chance of success with ethernet.)

| improve this answer | |
  • 1
    It does also work over WiFi – joscas May 2 '14 at 19:35
  • 1
    I have a iMac mid-2011, boot failing - and it's not the 'D' that Apple says, but Option-D that starts the H/W Test. I can connect by Ethernet or WiFi. – JezC Oct 23 '14 at 12:14
  • Can confirm it works over wifi and is quick to download (couple of minutes on a not particularly fast cable connection). – Foliovision Aug 28 '16 at 20:10
6

Same thing here (similar model MBP, same mods). Learned that Option+D does the trick. However, if you get what I see, the AHT fires up and then says that it doesn't support this model of machine. No funny business, it's an Apple MBP (no hackintosh here), but I added a OCZ Vertex 3 and I've tried pre-8GB RAM kit (stock) and post, no difference.

| improve this answer | |
  • 1
    I get this exact same issue: "AHT does not support this machine." I think this means you're supposed to run apple diagnostics, but for some reason have AHT installed instead. – Zach Mar 10 '14 at 18:19
  • Option-D worked for me as well on an early 2011 MBP 17 inch. I've got after sales RAM and a Samsung 840 512 GB SSD in there and had not trouble getting to Apple Hardware Test. – Foliovision Aug 28 '16 at 20:09
2

Its Option + D that works for me. Macbook Pro, Late 2011 model running Mavericks.

| improve this answer | |
1

Click on your embedded link again - the answer is just beyond the instructions for the "normal" startup method that you've been unsuccessful with:

Additional Information
Apple Hardware Test is included on the DVDs that are shipped with some Macintosh computers. If the copy on your hard drive becomes unavailable, use the DVDs to run Apple Hardware Test.

That should get you going.

If you are running Lion and do not have install DVDs, try re-installing your old RAM (assuming you have it) and running AHT.

| improve this answer | |
  • 1
    I would bet that many people have inadvertently erased their HD based diagnostics without realizing it. Thanks for pointing out the need to use the original media when the expected keys are not summoning AHT at boot. – bmike Nov 12 '12 at 12:52
1

Just to check, do you have internet access when you are doing the hardware test? According to you link

An Internet-enabled connection via Ethernet or Wi-Fi is required to use this feature.

| improve this answer | |
  • The problem is - for me at least - that it won't boot into the AHT, not that I can't connect. – Dave Apr 13 '12 at 14:49
  • The last time that I've done the AHT, an Internet connection was established via Wi-Fi. But this time, neither Wi-Fi nor ethernet will work. – gentmatt Apr 13 '12 at 17:02
1

I have an early 2011 Macbook Pro 13", which I first replaced the hard drive (totally blank and repartitioned), then installed Mountain Lion, then upgraded to Mavericks.

There appear to be two parts to the problem:

1) Swapping out a raw hard drive causes the loss of a hidden diagnostics/recovery partition (that I never bothered to look for, and which doesn't appear to be visible using Disk Utility.

2) The Apple KB article for Apple Hardware Test - http://support.apple.com/en-us/HT201257 - appears to be incorrect. The correct sequence to invoke the AHT is:

OPTION-D during a restart.

Performing a restart and holding OPTION-D eventually produced a "Internet Recovery" screen, and then automatically started the AHT by itself (the quaint, OS9-styled screen).

| improve this answer | |
  • Option-D and entering my wifi password did the trick. Cool OS 8 look. – Foliovision Aug 28 '16 at 20:06
0

The Apple KB article is inaccurate. After many unsuccessful attempts to launch the Apple Hardware Test on my MacBook Pro Early 2011 15",I discovered you need to hold Command + D during startup, not just D.

| improve this answer | |
  • This does not work on my MBP. – gentmatt Apr 14 '12 at 6:32
  • David wasn't paying attention. As others have noted, it's not plain D, it's not command-D but option-D on 2011 MBP (mine is a 17 inch). – Foliovision Aug 28 '16 at 20:08
  • Command-D didn't work for me. As for option-D, according to apple, option-D is for loading it over the Internet. Alas, that's not working either, at least for me. Single-user (command-S) and verbose mode (command-V) both work. I wish they had a menu option, to choose what to do from there. – lindes Feb 17 '18 at 5:21
0

Most Early Macs - PRE 2011 or 10.6.3 White Retail Disk(one that came w/your Mac) installed FIRST..BEFORE Booting up w/D-Key pressed!

| improve this answer | |
  • 1
    This might be better as an edit to make the existing answer that says boot with the D key pressed more complete – bmike Nov 12 '12 at 12:53
  • 3
    Could you please rephrase your post? I have a hard time understanding it. – gentmatt Nov 12 '12 at 14:31
0

I ran into similar situation with my mid 2011 mac-mini (with non mac keyboard/mouse & aftermarket updated RAM). After pressing 'D' at startup it searches for internet, eventually asking to select wi-fi connection (no available connections displayed though). There's an option to specify wi-fi access point name & password but for me after putting the credentials the wait icon just kept revolving. Thankfully, I got it working using the ethernet cable.

| improve this answer | |
0

Struck out with "D" and command+D. Option+D worked for me, too. Late 11 MacBook Pro 15.

| improve this answer | |
  • I'm also on a 2011 MBP, mine is 17 inch. Option-D during startup got me the hardware test as well. Thanks. – Foliovision Aug 28 '16 at 20:07
0

Alt+D using a Windows keyboard.

| improve this answer | |
  • A Windows keyboard does not affect the key combination; could you expand your answer to explain further? – grg Aug 21 '14 at 18:11
  • 2
    Using a Windows keyboard certain does affect the key combination. A Windows keyboard doesn't have a key that is referred to as "option" Alt+D is the correct combination on a Windows keyboard. – andynormancx Apr 5 '15 at 15:57
  • It is and the option key on OS X keyboards also is referred to as the "alt key" or the "alt/option key" in addition to "option key". That's probably why it says "alt" on this important key on most Apple keyboards. – MiB Feb 29 '16 at 12:43
0

I've had a similar problem whilst trying to run tests on a second hand Mac mini (Late 2014). I tried holding D, alt-D, cmd-D, cmd-R, alt-cmd-R, and two different wired keyboards, but each time the machine would just boot to the normal login screen.

I then reset the SMC (on this machine: unplug power cord, wait 15 secs, replug, wait 5 secs, power on - see Apple's HT201295). And now alt-D boots to Apple Diagnostics (which has replaced AHT for this model), as expected. Also, alt-cmd-R now boots to Internet Recovery (this key combination was also previously being ignored).

Perhaps here, the SMC was holding onto network information from the previous owner and getting thrown by the different network environment in my house until it was reset. Disappointing there were no error messages if that is the case.

| improve this answer | |
0

Mid 2012 MBP here. Just bought it and wanted to run AHT. Tried D, CMD D and OPT D, all bring same thing: "Internet Recovery". I have ethernet cable plugged in but it ignores that and wants wifi password (grr). I enter wifi password, then it connects but bugs out with black screen error: https://postimg.cc/HVq0fbZp

(The machine has had an SSD installed and 1TB HDD in drive caddy).

Hoping someone can suggest anything. I really want to verify the hardware is good before I commit to keeping this machine. thanks

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .