1

This post will (probably) only be relevant for UK users.

My internet is exceptionally slow (like so slow I don't even have the bandwidth to run a speed test) on my MacBook Pro, but fantastic in all other devices, including an iPhone, an Android phone and two PCs. The speed is slow regardless of where I am in my flat. It is a Virgin Media specific issue, as my internet speed is fine when I connect to any other wifi. I have already tried all the obvious steps:

  1. I have restarted the hub, to no avail.
  2. I googled it. It seems to be a relatively common issue with Virgin Media hubs and MacBook Pros – for example, see here and here – but none of the posts I could find provided a solution.
  3. I have reached out to Virgin Media support. They sent out a technician but the guy said there was nothing he could do, as it was a device-specific problem.

Any suggestions? I have a Virgin Media hub 5 and a 2022 MacBook Pro running macOS Ventura 13.5 (22G74).

1
  • Try connecting via Ethernet
    – mmmmmm
    Commented Aug 11, 2023 at 14:53

2 Answers 2

2

This "phenomenon" isn't limited to the UK as it happens here in the US as well.

I've run into this situation many times and not just with Mac computes. What I have observed is two fold:

  • The ISP supplied WiFi routers are built to cost rather than quality. In other words, the wireless chip sets that they use aren't very forgiving.
  • Apple (Dell as well) tweaks the WiFi drivers to maximize battery life over performance. I've noticed (using WiFi heat map tools) that on MacBooks running Windows via Bootcamp the transmit power registers higher values than when running in macOS. Higher transmit power = more battery draw.

I've solved this issue of poor WiFi performance many times by getting a quality WiFi router like a Ubiquiti AP or one of the higher-end Netgear routers. Additionally, you don't want to lease out the management/ownership of your firewall. Remember, if another entity owns something, they can also access it.

Get a quality AP or firewall and put that between your network and the ISP's equipment. You'll get better performance and security.

0

Posting the answer here in case it's helpful to someone else: after playing around a bit I found what the actual problem is: the Virgin Media router for some reason doesn't like it when the “Limit IP address tracking” option is on. I simply turned it off and the connection is back at full speed.

4
  • All the more reason to get your own (not acquired from the ISP) router you control. By disabling that feature, you disable privacy.
    – Allan
    Commented Aug 19, 2023 at 13:40
  • Where/how do you turn this feature off?
    – StudioTime
    Commented Jan 19 at 15:10
  • @StudioTime, System Settings > Network > Wi-Fi > the “Details” buttom next to your network > deselect the “Limit IP address tracking” checkbox. Commented Jan 20 at 16:14
  • Many thanks @LucasDeAbreuMaia
    – StudioTime
    Commented Jan 20 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .