I just upgraded my system to Ventura from Monterrey and I'm running into an annoying issue with how it handles multiple desktops. Whenever I maximize a window in one of my three monitors, the other two monitors go blank. Supposedly, this issue predates Ventura, which is a huge surprise to me:


I've never encountered this issue before Ventura. The solution is to check off Displays have separate Spaces, which is worse than the solution since I lose the ability to easily drag around windows.

Is there a solution for this or is this a feature?

  • It's a feature & has been that way for a decade or so. The 'fix' is to not use fullscreen, use maximise instead [opt green dot]
    – Tetsujin
    Commented Aug 11, 2023 at 6:15
  • That's what I thought I was using.
    – ATL_DEV
    Commented Aug 11, 2023 at 17:26
  • Green dot goes to fullscreen, which will blank all other displays in 'single Space'. Opt/green dot will just expand the window, not transition to fullscreen. See apple.stackexchange.com/questions/462910/… for variations on 'maximise'.
    – Tetsujin
    Commented Aug 11, 2023 at 17:37
  • Thanks. Weird. I must have had a different setting. Anyways, making the green "fullscreen" as the default behavior is a poor design choice. I've never been a fan of the traffic lights. The rightmost title bar zoom and close boxes in Classic MacOS was way more intuitive. Sometimes you wonder if such design decision were made to avoid patent litigation.
    – ATL_DEV
    Commented Aug 11, 2023 at 17:46


You must log in to answer this question.

Browse other questions tagged .