This keeps popping up in the upper right of my screen, it blocks access to anything underneath and I can't get rid of it. How do I disable this? I believe it's referring to my ECHO but who knows.

FaceTime Call via iPhone popup

  • What is an ECHO? Aug 8 at 22:01
  • You have set up your Mac to be able to answer calls made to your iPhone. This is the notification of such a call. Specifically, Settings >> Phone >> Calls on Other Devices is enabled. Aug 8 at 22:34
  • It appears you have an iPhone with WiFi calling enabled.
    – Allan
    Aug 8 at 22:34
  • 1
    @allan WiFi-calling is routing of mobile calls via WiFi instead of the carrier network.
    – nohillside
    Aug 9 at 5:48

1 Answer 1


I would disable WiFi calling on my iPhone and see if that resolves this issue. Here is how to do it:

  • On your iPhone, go to Settings > Phone > Calls on Other Devices, then turn off Allow Calls on Other Devices.

  • On your Mac, open the FaceTime app, choose FaceTime > Settings (or Preferences), then deselect Calls From iPhone.

Restart the Mac if a test call to your phone still rings the Mac. See the Apple support webpage "Make and receive phone calls on Mac or iPad" for more details.

  • The popup appears when making a call from your Mac to a phone, using your iPhone. First option will disable this option (and call reception) on any device signed on the same Apple ID. Second option will only disable making / receiving calls on your Mac. I suspect you will notice what's missing when you make the change, and adjust accordingly. It's easy to forget how are you making the call when your AirPods change their connection automatically according to focus. Aug 9 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .