2

On my system I can cut and paste text reliably, it works 100% of the time.

However copying text does not always copy, and when I paste I can get the previously copied item. This has been going on for several years, and I've experienced it across multiple power cycles, and multiple Macs, including both Intel and Apple silicon devices. I've also experienced it at a minimum across MacOS 13/12, and possibly earlier.

I've had situations when I've tried to copy URLs or text from chrome into slack or VSCode and found older clipboard contents were pasted, and I've had to cut rather than copy despite multiple attempts to copy to rule out not holding the keys properly or mis-clicking.

I've disabled continuity in hopes that this was lag in the universal clipboard, but it has not helped. I also see this behaviour with both CMD+C and right click->copy. The pbcopyCLI command works reliably from what I've noticed but I'm not sure.

How do I test and debug this to get technical information on failed copies? Is there a command or UI in MacOS to identify apps that might be interfering with this?

4
  • Copying what? That you say cut/paste works makes me think you mean text, not files [because Finder has no cut] Are you trying to paste to a like location, ie not one that prefers the killring, like Find. Example pasting to the answer space here vs opening find, which fills from the killring - i.stack.imgur.com/zLPrr.png
    – Tetsujin
    Aug 1, 2023 at 15:14
  • I've experienced this primarily with text, I can't remember a situation where it happened with a file but i can't rule that out. Most of the time it's copying text or URLs into things like slack or VSCode, or other boxes in chrome windows. E.g. if I copy pasted my answer into VSCode, there's a chance it might instead paste a URL I had just pasted into slack instead. I recently went through a flickr photo album in chrome copying URLs into a VSCode tab and noticed I had a lot of photos were missing as they did not copy and instead I got duplicated URLs Aug 1, 2023 at 15:21
  • I've also had situations where I copy pasted from chrome into slack, got an older clipboard entry, and gone back to try again and gotten the same result, with the clipboard only updating when I explicitly cut the text instead of copying despite 3 or 4 attempts with both keyboard and mouse Aug 1, 2023 at 15:23
  • 1
    hmm… I don't use Slack, Chrome, or VSCode so there's nothing I can check, sorry.
    – Tetsujin
    Aug 1, 2023 at 15:27

1 Answer 1

1

My first thought is that something is overriding the key command for some other function. It it's not working even from the main menubar, then we can rule that out (and hardware problems with the keyboard).

If you've got lots of Login Items, menulets, (mouse drivers?), and other background processes, it's possible that one of those might be interfering. Do you have a Pasteboard Manager app, like CopyClip?

I would start with the usual tests -- see if the problem occurs in Safe Boot mode; or in a brand new user account.

I find the system report generated by EtreCheck very useful for identifying all sorts of crap that is loading into the system, which you might have forgotten about.

1
  • I don't have any dedicated apps for the clipboard, only 1password for 2FA codes but that isn't always running Jan 1 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .