0

Firstly I'd like to say this is not the standard "my trash won't empty" question. My trash does empty but it won't empty correctly. What happens is when I click "empty trash" it will get stuck on "emptying trash" but it will never complete. If I don't wait long enough then the empty trash operation will not complete. But if I wait long enough it will empty AFTER I click the X on empty trash. I've attached a video.

This all started when I deleted a very large file. I originally canceled the operation because I thought it was taking too long but then I let it run for hours. I came back to it and hit the X button and then it emptied the trash. Now, every time I send a file to the folder--even a tiny one it will not empty the trash until I wait a few seconds (or minutes if it's a lot of trash) and then cancel the operation.

I've tried looking into the trash and seeing if there was anything there using ls -alF but there is nothing except . and ... I've also tried force removing the trash using sudo rm -rf ~/.Trash/* but nothing changes. Any ideas here? Do I need to rebuild some plist file or something somewhere? Thanks for reading.

https://drive.google.com/file/d/1rZKJayO5KtH3Hw2NeSwX1vIofWjQ6N5O/view?usp=sharing

4
  • Can you reproduce the problem while booted in safe mode?
    – Linc D.
    Aug 1, 2023 at 15:25
  • Are you certain the file is actually in ~/.Trash/? There are several trash folders on a Mac; at least one per drive & one per user.
    – Tetsujin
    Aug 1, 2023 at 15:58
  • @LincD. I will try that. Thanks!
    – Scott
    Aug 2, 2023 at 16:48
  • 1
    @Tetsujin yeah. I validated that the file is in ~/.Trash before I emptied it.
    – Scott
    Aug 2, 2023 at 16:48

0

You must log in to answer this question.

Browse other questions tagged .